Message Boards Message Boards

Mathematica frozen -- possibly a bad update

GROUPS:

I just sent this in to Wolfram tech support:

Today I tried to do work with Mathematica on my laptop. As soon as the kernel starts it freezes evaluating the first cell – it just keeps running and won’t respond to an abort. I suspected a bad update.

I started Mathematica on my workstation, but disabled dynamic updating before launching the kernel. It evaluated the first cell (2+2) as usual. I then enable dynamic updating and repeated. That machine is now frozen as well.

I have tried both a fresh start and a complete uninstall/reinstall. Neither solved the problem.

I had work to do today – Please get this fixed SOON.

Both computer are running MMA 11.1.1.0 on Win7 x64.

POSTED BY: David Keith
Answer
6 months ago

I have a similar problem. My workaround is to enter a simple first cell, evaluate it, and then abort evaluation. After that, everything seems to work ok. However, task manager tells me I have 2 kernels running.

POSTED BY: Frank Kampas
Answer
6 months ago

That worked for me at first. Now I can't even open a new notebook. There is a running thread on this a SE as well. I am now getting kernel licensing issue errors. It probably thinks there are too many kernels running, but Task Manager does not see them. This is really really bad.

POSTED BY: David Keith
Answer
6 months ago

Have seen this on both my windows and mac version and for both versions 11.1.1 and 11.1.0 btw. Even simple things like 1+1 can take very long time for the first evaluation! Sometimes taking 'forever', sometimes actually evaluation correctly but after 20-30 secs. Once it is evaluated; it works fine... I suspect some kernel <> frontend connection issue...

POSTED BY: Sander Huisman
Answer
6 months ago

There is a discussion of this on SE: Stack Exchange

POSTED BY: David Keith
Answer
6 months ago

I moved the paclets directory (In win 7: c:/users/user/appdata/roaming/mathematica/paclets) to the desktop so Mathematic couldn't find it. Then turned off internet access at the OS, and started Mathematica. It starts normally and the kernel loads and returns instantly. Now, how to live without the internet?

POSTED BY: David Keith
Answer
6 months ago

The hints on StackExchange solved my troubles: Re-Installing Mathematica, but deleting $UserBaseDirectory first. Frontend-kernel connections works like before. I hope there will be no evil update again...

POSTED BY: Heiko Sippel
Answer
6 months ago

I have the same issue. Then MM started complaining my license was invalid? I started MM10.2 and then 11.1.1 got a lot of beeps and after a restart (windows) MM 11.1.1 starts again without licensing issue. I noticed that the issues started after I logged in through the splashscreen (welcome screen) to the wolfram cloud. Weird and very annoying. I suspect a license check during the first evaluation? Normally when I'm online and start MM you get the welcome screen and even without logging in to the cloud it seems MM is trying to connect or check something. When I start MM in flightmode the welcome screen (the connect box in the left upper corner) is not doing anything. But then after I open a notebook and start a cell with 1+1 it keeps running and the abort doesn't work. The abort only works when I have or had a connection during MM startup. I hope this gets fixed fast.

POSTED BY: l van Veen
Answer
6 months ago

For a workaround, launch a standalone kernel and evaluate

PacletUpdate["EntityFramework"]

More detailed instructions can be found here (except substitute "CloudObject" with "EntityFramework").

POSTED BY: Ilian Gachevski
Answer
6 months ago

I've wondered for a while when paclet updates are checked for? Is it periodically? or triggered by usage of certain features in the language? or at startup? or ... ?

POSTED BY: Sander Huisman
Answer
6 months ago

launch a standalone kernel

Do you mean just close and open Mathematica?

POSTED BY: Kapio Letto
Answer
6 months ago

I launched a kernel, no notebook, from the command line, and ran the PacletUpdate. I believe that the notebook interface does things that cause a kernel to be launched, and it was getting wedged by the bad paclet data?

POSTED BY: Flip Phillips
Answer
6 months ago

Thank you, Ilian. Does this mean it's now fixed, and an update will correct it? I only just got mine running by deleting the paclet directory.

POSTED BY: David Keith
Answer
6 months ago

As of right now, the broken paclet is being removed from the servers, which may take a few minutes.

Subsequent start-ups should be fine (if for some reason they are not, delete the Paclets directory).

POSTED BY: Ilian Gachevski
Answer
6 months ago

wrong! I'm getting a message I saw on occasions with this problem "Updating from Wolfram Research Server (0%)"

POSTED BY: Frank Kampas
Answer
6 months ago

Hi Ilian,

Is there a reliable way to get Mathematica working in the situations like this without waiting until the broken paclet(s) will be removed from the servers? Or just without Internet access?

POSTED BY: Alexey Popkov
Answer
6 months ago

looks like it's fixed now

POSTED BY: Frank Kampas
Answer
6 months ago

I spoke too soon. It's still there.

POSTED BY: Frank Kampas
Answer
6 months ago

So, wasted literally 2+ hours today chasing this down. Was still being problematic @ home, but doing the EntityFramework update seems to have fixed it for now.

Oh paclets

POSTED BY: Flip Phillips
Answer
6 months ago

Who said that the issue is already fixed?

Yesterday I was about to uninstall and re-install Mathematica 11.1.1 but decided to wait till today in case Wolfram fixed the problem.

But I am having trouble yet. (11:13 CET).

Even more, the access to Mathematica 11.1.1 has been blocked.and I cannot launch the kernel to run PacletUpdate["EntityFramework"].

I have got in touch with Customer Services because now, in addition to the “Mathematica frozen -- possibly a bad update” initial issue, I have a license related problem: the kernel says my password is invalid.

Martin.

POSTED BY: Dr Martin
Answer
6 months ago

Additional info.

It seems that the trouble is not with the license password (in fact it should not).

  • I launch Mathematica, and the frontend works (the initial window pops up)
  • The frontend launches the kernel which submits the invalid password warning
  • I quit the invalid password warning window
  • The frontend keeps working but only takes the actions that do not require kernel interaction
  • As soon as I submit any action which requires the kernel Mathematica freezes

This means to me that Mathematica is working 'partially': it is not a true password problem in itself but a problem with the way the kernel treats the situation, if it were an actual password problem neither the fronted nor the kernel would work.

POSTED BY: Dr Martin
Answer
6 months ago

Mathematica 11.1.1.0 - Windows 10:

Had the same problem. Mathematica.exe didn't respond anymore (kernel is not responding to a dynamic evaluation ....) while MathKernel.exe and WolframKernel.exe were still working. Simple re-run of setup.exe did't help. Had to first unistall via windows. Then I deleted all remaining mathematica folders (also in appdata/..... and in .../ProgramData/....) and made a fresh install. Currently I see no issues anymore.

Let's see how long it works.

Walter

POSTED BY: Walter Haeffner
Answer
6 months ago

Hi, I had a busy week-end, too, trying to get Mathematica running. The connection frontend to kernel seems to be broken like so many other users described it here. I sent an error description to the service desk and got an answer in short time (thank you!). As many other perople are experiencing this problem, here ist the proposed solution:


We made a few updates to Mathematica last week which resulted in your installation not being able to launch the mathKernel as normal in versions 11.1.x.

Please close any instances of Mathematica or WolframKernel that are running in the background.

=====================================================================

a) Launch WolframKernel using the following step(s):

For Windows:

Start menu -> Search for 'Mathematica 11.1.1 Kernel' and launch it

For Mac:

In Finder -> Applications -> Right click Mathematica (control click) -> Show Package Contents -> Contents -> MacOS -> Double click WolframKernel

For Linux:

In Terminal evaluate: /usr/local/Wolfram/Mathematica/11.1.1/Executables/WolframKernel

b) In the launched WolframKernel evaluate

PacletSiteUpdate /@ PacletSites[]

PacletUpdate["EntityFramework"]

===================================================================== If you are still encountering issues after following these steps, please let us know.

Sorry for any inconvenience caused by this issue. _____________________________________

POSTED BY: Heiko Sippel
Answer
6 months ago

Yes - the last days I experienced the same issues. I still have Windows 10 (1511). Have also seen two kernel processes.

Walter

POSTED BY: Walter Haeffner
Answer
6 months ago

I am having a similar issue with Mathematica 11.1.1 on macOS Sierra. Executing 2 + 2 is taking an extraordinary amount of time. I will investigate,

POSTED BY: George Woodrow III
Answer
6 months ago

I'll add my MMA 11.1.1 installation to the list of those having this issue. The solution posted on Stackexchange with Ilian's modification in his post above worked for me. I hope WRI is working to make sure this doesn't happen again.

POSTED BY: David G
Answer
6 months ago

Wolfram Technical Support has verified that the following steps address the problem in most cases, they are expanded versions of Ilian's previous comment:

Windows:

  1. Close any open Mathematica applications (front-ends).

  2. Open the Windows Task Manager by pressing the keys CTRL+SHIFT+ESC.

  3. In the Task Manager window, check for any instances of “Wolfram Kernel” or “Wolfram Mathematica”.

  4. Close them all by selecting them one by one and clicking on “End Task” button.

  5. Start the Mathematica Kernel, using the following steps:

    http://support.wolfram.com/kb/12414

  6. Evaluate the following in the Mathematica Kernel:

    PacletSiteUpdate /@ PacletSites[] 
    PacletUpdate["EntityFramework"]
    
  7. Close the Mathematica Kernel.

  8. Start the Mathematica application (front-end).

  9. Verify that Mathematica works as expected again by evaluating 2+2.

Mac:

  1. Close any open Mathematica applications (front-ends). Use 'Force Quit' if necessary.

  2. Open the Activity Monitor: press Command+Space, type “Activity Monitor” in appearing Spotlight search field, press return to confirm

  3. In the Activity Monitor window, check for any instances of “WolframKernel” or "Mathematica”.

  4. Close them all by selecting them one by one and clicking on “Force Quit” button in the dialog box.

  5. Start the Mathematica Kernel, using the following steps:

    http://support.wolfram.com/kb/12414

  6. Evaluate the following in the Mathematica Kernel:

    PacletSiteUpdate /@ PacletSites[] 
    PacletUpdate["EntityFramework"]
    
  7. Close the Mathematica Kernel.

  8. Start the Mathematica application (front-end).

  9. Verify that Mathematica works as expected again by evaluating 2+2.

Linux:

  1. Close any open Mathematica applications (front-ends). Use force quit if necessary.

  2. Open a Terminal by pressing CTRL+ALT+T.

  3. In the Terminal, kill all instances of “Wolfram Kernel” or “Wolfram Mathematica”, by evaluating the following commands:

    ps -ef | grep Mathematica | grep -v grep | awk '{print $2}' | xargs kill -9 
    ps -ef | grep WolframKernel | grep -v grep | awk '{print $2}' | xargs kill -9
    
  4. Start a Mathematica Kernel, using the following steps:

    http://support.wolfram.com/kb/12414

  5. Evaluate the following in the Mathematica Kernel:

    PacletSiteUpdate /@ PacletSites[] 
    PacletUpdate["EntityFramework"]
    
  6. Close the Mathematica Kernel.

  7. Start the Mathematica application (front-end).

  8. Verify that Mathematica works as expected again by evaluating 2+2.

Please contact Wolfram Technical Support if these steps do not work for you.

Hope this helps,

Peter Fleck

POSTED BY: Peter Fleck
Answer
6 months ago

better and worse. When it hangs up, abort evaluation doesn't work, which it did before. Sometimes it doesn't hang up.

POSTED BY: Frank Kampas
Answer
6 months ago

This is working for me, so far. However, I first deleted the paclets directory. I'm on Win 7 x64.

POSTED BY: David Keith
Answer
6 months ago

I followed the procedure -- using live chat from Wolfram Tech support, and it worked. It turned out that I had two 'phantom' math kernels running.

I had already removed my $UserBaseDirectory and re-installed Mathematica, but that might not have been necessary.

In any case, I am back in business.

My question is: how does a user prevent this from happening. I am thinking of people using Mathematica in a production environment, where any changes (e.g., packet upgrades) need to be vetted before use.

POSTED BY: George Woodrow III
Answer
6 months ago

I had a bad weekend as well - and re-installed Mathematica twice and in vain ... But those things just happen; I am sure Mathematica is a monster in terms of complexity. And that episode just revealed how addicted I am by now.

POSTED BY: Henrik Schachner
Answer
6 months ago

I had the same problem that is being discussed here.

I downgraded to Version 11.1.0.0, and it seems to be working okay. I hope that they get a fix out pretty soon.

--David

POSTED BY: David Jacobson
Answer
6 months ago

HI -

The problem had to do with a bad paclet, so the fact that you are doing ok means that the problem was fixed for you because you do not have the 'bad' paclet. You can probably (weasel word) upgrade to 11.1.1 with no issues. If you do have issues, the instructions provided elsewhere on this thread will fix the problem.

POSTED BY: George Woodrow III
Answer
6 months ago

Just to confirm: it is safe to upgrade to version 11.1.1. As Ilian had pointed out earlier, the paclet in question has been removed from the servers. For those affected the instructions I posted above have been very effective.

Peter Fleck

POSTED BY: Peter Fleck
Answer
6 months ago

Note to self- my next band will be named Bäd Päclet.

yep

POSTED BY: Flip Phillips
Answer
6 months ago

has this been fixed in 11.1.1.0 ?

POSTED BY: John Hendrickson
Answer
4 months ago

The paclet was fixed at the time and Mathematica 11.1.1 is working well with it. We have not heard of any customer having this issue for numerous weeks.

If you still encounter it, please try Ilian's or my steps from the respective previous posts, otherwise contact Wolfram Technical Support.

Thank you,

Peter Fleck

Manager, Wolfram Technology Group

POSTED BY: Peter Fleck
Answer
4 months ago

Group Abstract Group Abstract