Message Boards Message Boards

Package have unmet dependencies when upgrade Wolfram-engine

GROUPS:

I've try to upgrade Wolfram engine on my Raspberry pi 3, but have this error My Raspbian already latest version, When I try to upgrade engine by sudo apt-get upgrade wolfram-engine I've got this

`the following packages have unmet dependencies:`

Depends: libhunspell-1.4-0 but it is not installable
Depends: libssl1.0.2 but it is not installable
Depends: coinor-libipopt1v5 but it is not installable
Depends: libraw15 but it is not installable

How can I fix this error?

POSTED BY: Artemii Chekushin
Answer
4 months ago

Hi Artemii,

What version of Raspian are you running? You might need to try cleaning out the apt-cache and trying to install wolfram-engine again with:

sudo apt-get purge wolfram-engine
sudo apt-get clean
sudo apt-get update
sudo apt-get -f install
sudo apt-get install wolfram-engine

This will first remove all previous installations of the wolfram-engine, then cleans out any local cached versions of apps that were downloaded but not installed (or also deletes all the installer tarballs, etc that aren't used after an app is installed), then updates the cache, attempts to fix any previous botched installations, then finally will attempt to re-install wolfram-engine.

Let me know if this works for you.

Thanks,

Ian

POSTED BY: Ian Johnson
Answer
4 months ago

Thank you Ian! This solution work for me!

POSTED BY: Artemii Chekushin
Answer
4 months ago

Great, I'm glad it worked for you.

Ian

POSTED BY: Ian Johnson
Answer
4 months ago

Group Abstract Group Abstract