Message Boards Message Boards

Avoid unexpected change on the Keyboard layout?

GROUPS:

Hi there, I'm currently using Mathematica 11.1 and have recently been facing a recurring issue I have never encountered before. At some point in an active kernel session my keyboard layout will change from UK English to something else (unsure, but maybe Australian English). This only within Mathematica, all other programs continue to recognise a UK English keyboard. This is frustrating as it changes the location of some of my most used keys (e.g. ", @, #), and cannot be reverted except by killing the kernel and restarting Mathematica. I've looked through the settings and online for an "input keyboard layout" setting, but can't find anything. I also have no idea what causes it to change other than some keyboard shortcut which I accidentally press without realising. Any help which can be provided will be greatly appreciated!

POSTED BY: Billy Kyle
Answer
4 months ago

Are you using Windows 10? If so I had a similar problem. And found the fix by googling around.

POSTED BY: Hans Milton
Answer
4 months ago

I'm not, I'm using Windows 7, however the same issue has been encountered by my colleague who has windows 10.

POSTED BY: Billy Kyle
Answer
4 months ago

Group Abstract Group Abstract