Message Boards Message Boards

Avoid issue with ResourceData caching in Windows?


I have the following code to load the CIFAR-10 resource data...

cifarRO = ResourceObject["CIFAR-10"];
cifarTraining = ResourceData[cifarRO, "TrainingData"];

I am running Mathematica 11.2 on Windows 10 and on Mac OS (High Sierra). When I run this code on either machine it first loads the ResourceObject and then will cache the ResourceData (Which is around 180 MB). However, on the Windows machine the ResourceData function returns $Failed. Does anyone know why my Windows version of Mathematica may be having trouble?

As a temporary solution I have cached the data on my Mac version and then saved the data out using Export[], which I then load in on the Windows version. This seems to work fine but it is cumbersome to have to cache the data in this way.

POSTED BY: Lenny Johnson
23 days ago

You can remove the cache on Windows using this


And try ResourceData again.

POSTED BY: Bob Sandheinrich
21 days ago

I had already tried this. The resource data downloads again (And appears to dl it all) but then the data Length is still zero. I assume the issue is not necessarily with a bad locally cached resource.

POSTED BY: Lenny Johnson
18 days ago

Group Abstract Group Abstract