Group Abstract Group Abstract

Message Boards Message Boards

Why does AxesLabel lose first characters in 3D plots? (Mma 8.0.0.0, RHEL6)

GROUPS:
Hi, this is my first post so let me know (gently emoticon if I'm not doing this quite right.
I'm using Mathematica 8.0.0.0 on a Red Hat Enterprise Linux 6 PC, experienced with both Mathematica and Linux but not the combination.
When I invoke Plot3D or ListPlot3D and use AxesLabel, the first character of each label is cut off. So if I run
ListPlot[{{0, 0}, {0, 1}, {1, 0}, {1, 1}}, AxesLabel -> {x1, "x2"}]

everything's fine (labels are x1 and x2), but if I run
ListPlot[{{0, 0, 0}, {0, 1, 1}, {1, 0, 1}, {1, 1, 0}}, AxesLabel -> {x1, "x2", 33}]

the labels are 1, 2, and 3.  If I run
Plot3D[Sin[x*y], {x, 0, 1}, {y, 0, 1}, AxesLabel -> Automatic]

I get no axes labels at all.
I tried searching for this issue but can't find anything.  Has anyone seen this before?  The workaround is obvious (though I discovered that prepending a space character does no good), but it would be nice to actually fix.
P.S. Forgot to mention--the numbers which label the ticks also have their first characters cut off! So if the tick labels would normally be 0.0, 0.5, and 1.0, I only see .0, .5, and .0 again.
Answer
11 months ago
Your post was fine.

With the second plot (ListPlot3D), do the missing characters appear if the plot
is rotated or expanded?

I did not see a problem with 9.0.1 on Ubuntu or 8.0.4 or 7.0.1 on MacOS 10.8.

You can add a screen shot to a post by saving the screen shot to a file on your computer
and uploading it with the image ikon, , then in the window that opens click Upload.
POSTED BY: Bruce Miller
Answer
11 months ago
Thanks for your reply, and yes, somehow the "3D" got left off the second command line above--it was a ListPlot3D.  The missing characters do not appear if I rotate or expand the plot.  I attach a screen shot:
Any ideas?
Answer
11 months ago
Strange.  I created some (close) data and there is no first-character clipping.

My suspicion is that a start-up file was damaged somehow and Mathematica
starts in a non-standard state.

- The first test is to hold down the SHIFT key as Mathematica starts (until a Mathematica window opens). 
  Copy the inputs from this notebook into a new notebook and evaluate there.

- If that does not correct it, try including the -clean command-line option when starting Mathematica
      mathematica  -clean &
That also resets global preferences and the list of recently opened notebooks.

I did not find a problem report like this.  It is possible that this was only in 8.0.0 and was
fixed in 8.0.1.  You could ask Customer Service (info@wolfram.com, 217-398-5151)
if an upgrade to 8.0.1 (or later 8.0) would be available. 
POSTED BY: Bruce Miller
Answer
11 months ago
I tried both suggestions, and I'm afraid neither had any observable effect.  I guess my next step is to contact Wolfram as you suggest.
Answer
11 months ago