Group Abstract Group Abstract

Message Boards Message Boards

CUDALink with Mathematica is NOT working


I have the following configuration.

Windows 7 Enterprise 64 bit, Cuda Toolkit 6.5, Mathematica Standard Version 10

The output from CUDAResourcesInformation[] is

{{"Name" -> "CUDAResources", "Version" -> "", 
  "BuildNumber" -> "", "Qualifier" -> "Win64", 
  "WolframVersion" -> "10+", "SystemID" -> {"Windows-x86-64"}, 
  "Description" -> "{ToolkitVersion -> 6.0, MinimumDriver -> 270.0}", 
  "Category" -> "", "Creator" -> "", "Publisher" -> "", 
  "Support" -> "", "Internal" -> False, 
  "Location" -> 
   "C:UsersmumasuthAppDataRoamingMathematicaPaclets\nRepositoryCUDAResources-Win64-", "Context" -> {}, 
  "Enabled" -> True, "Loading" -> Manual, 
  "Hash" -> "8cd86e25825c095afcb781fa82d3cf73"}}

The output from CUDADDriverVersion[] is 340.62

However CUDAQ[] returns False.

I'll appreciate any pointers to resolve this issue. Thank you in Advance.

POSTED BY: Manickam Umasuthan
1 year ago

I don't know very much about CUDALink, but I would first try updating the paclet:

After this I would try resetting Mathematica's configuration to its installation default settings:

And then run the command RebuildPacletData[].

If neither of these help, I would contact Wolfram Technical Support. I would email them, since they may have to look into the issue. When emailing them, include your activation key for Mathematica ( evaluate $ActivationKey to find this ) and a Mathematica notebook where you have evaluated the command


This notebook will give them more information about your installation's configuration on the machine and may help them resolve the issue.

POSTED BY: Sean Clarke
1 year ago

Thank you very much for the reply.

I still get "False" as output for CUDAQ[].

As you suggested I would contact the Mathematica Technical Support.

Regards, Manickam

POSTED BY: Manickam Umasuthan
1 year ago

I had a similar issue on OS X. Forcing a reinstall via CUDAResourcesUninstall[] followed by CUDAResourcesInstall[] worked for me.

POSTED BY: Kirk Klobe
1 year ago