Message Boards Message Boards

Error code 702 on launch of Mathematica (Windows 10)

GROUPS:

Hello

I am testing Mathematica on Windows 10 and I am seeing the following error:

A serious error has occurred while Mathematica was starting up. Mathematica will probably not function properly until this problem is resolved. You may choose to continue anyway, but Mathematica may crash or exit without warning. ------------------------------ The installation of Mathematica may be corrupted. Contact Techincal Support or visit... for more information. Error Code: 702.

I am not given the option to continue anyway - only the option to Quit.

I have submitted this information over a week ago to Mathematica but have not received a response - not even an auto-response, not sure if this is normal or not?

Has anyone else encountered this error or similar before - any advice?

I do not see the same error when using the same installation on Windows 7.

Many thanks Sarah

Attachment

POSTED BY: Sarah B
Answer
1 year ago

Sarah,

I just got off Mathematica Tech Support chat and the solution that worked for me was the following. You will need to be an administrator on the system to make the changes but the below should get Mathematica working for you on Windows 10. They are pointing to the issue with a 3rd party app that is blocking internal Mathematica font installations from working or something like that

Run the registry editor. 1. Press Windows Key + R 2. Run regedit.exe

In the registry editor 1. Find the file path: HKEYLOCALMACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options 2. Right click on Image File Execution Options, and select New > Key 3. Rename the key to mathematica.exe 4. Right click on mathematica.exe, and select New > QWORD (64-bit) Value 5. Rename this to MitigationOptions 6. Double click on MitigationOptions, and change the value to 2000000000000 (that is 12 zeros). The base should be Hexadecimal.

Attachments:
POSTED BY: Andre Mosley
Answer
11 months ago

I just downloaded and installed Mathematica 11.0.1. At startup it generates error code 702 just as described by Sarah B. above and presents you only with the option to quit the program. I then implemented the registry fix in as given by Andre Mosley but to no avail. Uninstalled and re-downloaded for a fresh install a second time and got the same error.

Vversion 10 used to run just fine on my computer but version 11 will not.

Laptop HP Elitebook 8440p windows 10 Pro version 1511 OS build 10586.494 Ram : 8GB 64-bit operating system intel core i5 CPU M 520 @2.4GHZ

Kaspersksy firewall & antivirus was deactivated during installation.

Any ideas would be greatly appreciated:

POSTED BY: Stan Alkhaz
Answer
8 months ago

You said you implemented the fix that I posted, if so, it should have resolved the issue, assuming after you got the error you ensured that Mathematica was not running when you implemented the fix. After doing the registry fix, do you still get the same error message in the screenshot in this post.

I've installed Mathematica several times on Windows 10 systems using the fix and they all worked without issues. You might want to ensure that when you uninstalled Mathematica all traces of it removed (ie. make sure the folders on the hard drive were removed and deleted, no registry keys are leftover for Mathematica.

Additionally, it shouldn't matter but you're version of Windows 10 is out of data, the latest version of v1607 (Anniversary Update) which puts the build number up to 10493. If all of the aforementioned still doesn't work, your only option is to contact Mathematica chat or phone support.

Good luck.

POSTED BY: Andre Mosley
Answer
8 months ago

Yes, after doing the "Mitigations" registry fix to unblock untrusted fonts, I was still getting the same Error Code: 702 in the screenshot. So I removed this registry fix.

What I finally found was causing my issue was that the Windows firewall service was turned to "manual" on this computer. So all that was necessary was to run services.msc and set the windows firewall service to "Automatic" and Mathematica runs just fine now.

POSTED BY: Stan Alkhaz
Answer
8 months ago

While the steps Andre provided still seem to be one of the most common resolutions for the problem, if you are experiencing this issue with CDF Player you will want to use "WolframCDFPlayer.exe" instead of "mathematica.exe".

  1. Find the file path: HKEYLOCALMACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Image File Execution Options
  2. Right click on Image File Execution Options, and select New > Key
  3. Rename the key to mathematica.exe
  4. Right click on mathematica.exe, and select New > QWORD (64-bit) Value
  5. Rename this to MitigationOptions
  6. Double click on MitigationOptions, and change the value to 2000000000000 (that is 12 zeros). The base should be Hexadecimal.
POSTED BY: Kyle Martin
Answer
5 months ago

It is quite unnerving to suggest registry editing as a work-around. This should not be recommended. As such, and rather than disable any security software on my machine (Win10), once I understood that it was a font installation issue, and where the fonts were being stored, I was able to resolve the issue.

The following is a safer way to complete the installation. 1) After running the installation as administrator (which is successful), the program forces the user to quit. 2) Then going to the folder “C:\Program Files\Wolfram Research\Wolfram CDF Player\11.0\SystemFiles\Fonts\TrueType” where the fonts are stored after installation, I installed the fonts with administrator privileges, in batch (select all, right click, run as admin). 3) Open the program, no error should occur.

Check opening the program after manually installing the fonts in batch. I suspect that this may be the only required step after the initial installation.

To check this, I uninstalled the fonts, attempted to open the program, received the error, reinstalled the fonts and reopened the program. The program opened without error.

I hope this is helpful.

POSTED BY: Seth Meiselman
Answer
24 days ago

I would be curious to know why you had to disable your security software (and what security software you use). It is my understanding that all that is required is the registry key and Windows Firewall is enabled and running.

As for installing the fonts into \Windows\Fonts... It is not recommended, and could actually cause issues with future versions. That is why TS doesn't offer it as a solution.

POSTED BY: Ian Hojnicki
Answer
23 days ago

In my contact with TS, they offered three possible solutions:

1) checking to make sure any security software is not blocking external fonts- i.e. allow security exceptions for external fonts

2) turning off my firewall to see if this is the cause- then if it is allowing an exception for CDF Player

3) editing the registry.

I cannot make these security changes or registry changes on the system I am using. Font installation however can be done after an antivirus scan. After I installed the fonts, I sent a response to TS stating my solution and was given no warning by them that this could or would interfere with future versions. So I'm not sure why you would think this is the case. Even so, it's just as easy to remove the fonts if the developers fix this for a later version. But I doubt that would be necessary.

POSTED BY: Seth Meiselman
Answer
11 days ago

That's a great solution Seth, but as aforementioned the registry option is what Wolfram Support provided as the solution to the issue and up until that time there were no other alternatives to correct the issue but what they provided.

POSTED BY: Andre Mosley
Answer
24 days ago

Group Abstract Group Abstract