Message Boards Message Boards

Where can I get MRAALink version 1.0.5 (or higher)?

GROUPS:

Hi,

I am getting errors with Mathematica 11.0.1 on Raspbian with kernel 4.9.59-v7+. These are related to the supplied version of MRAALink which is 1.0.2 and version 1.0.5 (or higher?) resolves these errors (see other discussions in this group). PackletUpdate however says that no newer version of MRAALink is available. Where can I get version 1.0.5 (or higher)?

Thanks, Gijsbert

Answer
15 days ago

Hi,

What version of Raspbian are you running (independently of the linux kernel version)?

Thanks,

Ian

POSTED BY: Ian Johnson
Answer
15 days ago

Related to that, is there anything we users should pay attention to regarding Raspbian versions when using Mathematica? I'm still on Jessie, but I was planning to upgrade to Stretch soon.

POSTED BY: Szabolcs Horvát
Answer
15 days ago

The next release (11.2 probably) will only run on Stretch, not Jessie.

POSTED BY: Ilian Gachevski
Answer
15 days ago

Are you planning to maintain compatibility with the first generation Raspberry Pi?

POSTED BY: Szabolcs Horvát
Answer
15 days ago

As long as it is running Stretch it should be fine, though I haven't tested this myself on older boards.

POSTED BY: Ilian Gachevski
Answer
15 days ago

Hi Ian,

/etc/os-release shows version 9 (stretch).

Regards, Gijsbert

Answer
15 days ago

We have uploaded MRAALink 1.0.5 to public paclet server. You should be able to use it using PacletUpdate["MRAALink"].

In[4]:= PacletSites[]                                                                                               

Out[4]= {PacletSite[http://pacletserver.wolfram.com, Wolfram Research Paclet Server, Local -> False]}

In[5]:= PacletUpdate["MRAALink"]                                                                                    

Out[5]= Paclet[MRAALink, 1.0.5, <>]

In[6]:= Quit  

In[1]:= PacletInformation["MRAALink"]                                                                               

Out[1]= {Name -> MRAALink, Version -> 1.0.5, BuildNumber -> , Qualifier -> , WolframVersion -> 10+, 
 
>    SystemID -> All, Description -> , Category -> , Creator -> , Publisher -> , Support -> , Internal -> False, 
 
>    Location -> /home/pi/.WolframEngine/Paclets/Repository/MRAALink-1.0.5, Context -> {MRAALink`}, 
 
>    Enabled -> True, Loading -> Manual}
POSTED BY: Damanjit Singh
Answer
7 days ago

Hi,

Thank you for your prompt response and yes, this version resolved my errors!

Regards, Gijsbert

Answer
5 days ago

Group Abstract Group Abstract