Message Boards Message Boards

0
|
19240 Views
|
4 Replies
|
2 Total Likes
View groups...
Share
Share this post:
GROUPS:

Dsolve.. The Function appears with no argument..

Posted 11 years ago
DSolve[{k'[ t ] == k^3*t^2, k[1] == 3}, k[ t ], t]
and I get the error
DSolve::dvnoarg: The function k appears with no arguments. >>

I've tried clearing and using only one =, but neither seems to work. What's the problem?
Edit: there are no spaces in the brackets in the actual code, just put those in because they wouldn't show otherwise.
ty
POSTED BY: Daniel Winge
4 Replies

The argument of Log, and of all the functions in WL, must be within square braces [], not parentheses ().

POSTED BY: Gianluca Gorni
(1/T)(-Co + DCsT - Cp D ((Log (1 + R - t1)^2)/(1 + R - T) + t1) - 
  Cd D (-T + (Log (1 + R - t1)^2)/(1 + R - T) + t1) - 
  Ch (-((D t1^2)/2) + D t1 ((Log (1 + R - t1)^2)/(1 + R - T) + t1) + 
     D (1 + R) (-Log (1 + R - T) T + Log (1 + R - t1) t1 + 
        1/2 (T + 3 t1) + (
        Log (1 + R - t1) (1/2 (-1 - R) - T + t1 - 3/2 (R + t1^2)))/(
        1 + R - T))))

Differentiate with respect to T

Attachments:
Posted 11 years ago
Ah the k[ t ] ^3 also needed [ t ] .. didn't think so. 
Problem resolved.
Thanks.
POSTED BY: Daniel Winge
 
Somewhere in the input there is a 'k' which should be 'k[ t ]', in other words the function k appears without an argument. 
POSTED BY: Ilian Gachevski
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract