Message Boards Message Boards

GROUPS:

Export a plot in .eps format to be displayed in MS Word?

Posted 1 year ago
1439 Views
|
7 Replies
|
0 Total Likes
|

Hi, Any one help me in EPS format arrow in epilog. when i export plot in .eps then plot does not display in MS word

7 Replies

Hi Nasir,

Without any code, version, and operating system, and a proper title this topic will be removed. Please change your opening post.

Posted 1 year ago

sorry i did'nt understand your reply

Posted 1 year ago

i need help to plot a graph consist of arrow option in apilog command. i want to save in EPS format and also want to import on MS word.

This work for me:

Export["myArrow.eps", 
 Plot[x, {x, 0, 1}, Epilog -> Arrow[{{1, 0}, {1/2, 1/2}}]]]

It shows fine in MS Word.

Posted 1 year ago

Thanks Gianluca Gorni..

i am using MS word 2013, it is still not working. same error show in MS word. I import myArrow.eps on mathematical notebook it works properly but when import on MS-word then it is not working. kindly u also check this on MS word and also tell me which version of MS Office you are using.

I am using the most recent version of Word for Mac. Have you tried exporting as pdf or svg instead of eps?

here's a simple existence check

open the EPS, it's human readable. you'll see if it's capable of drawing and arrow by reading it

unfortunately at the top there will be many "wolfram function definitions" (in the postcript language) that setup fonts and such in the PS language. (you skip past that looking for the arrow drawing part of the file which should be at the end). these are not as correct as they were in previous versions (i think wolfram has slacked on it, thinking 3d is everything and 2d is nothing)

you could just post the .EPS here on this website, and someone else can try loading the file and tell you what they see.

MY ADVICE IS: make sure you have "Adobe Reader" installed: you need Wolfram fonts and likely adobe fonts installed in windows 10 for EPS files to view properly. Also: try viewing the first in Adobe reader before you try "Word 2013". unfortunately your using and OLD version of a microsoft product, so it may not be able to use the fonts and won't be supported by anyone for such a problem. the microsoft team (at wolfram and microsoft) are not the same as the Apple imac team. they may have changed fonts in some way.

also: you can read the EPS in mathematica by pressing (shift-apple-e, on apple) by using "show cell contents" after you've loaded the EPS in mathematica

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract