Message Boards Message Boards

GROUPS:

Load spline regression/smoothing R packages with RLink?

Posted 3 months ago
503 Views
|
3 Replies
|
6 Total Likes
|

I already installed several R packages, and called them from Mathematica without difficulties. But since yesterday, I'm trying to load spline regression/smoothing packages, unsuccessfully. For instance, it seem that "assist" is not properly loaded (same issue with "bigsplines").

In[15]:= InstallR[]
(*REvaluate["install.packages(\"assist\")"]*)
REvaluate["library(\"assist\")"]

(*REvaluate["install.packages(\"bigsplines\")"]


REvaluate["library(\"bigsplines\")"]*)


During evaluation of In[15]:= REvaluate::rerr: Failed to retrieve the value for variable or piece of code library("assist"). The following R error was encountered: Erreur dans library("assist") : aucun package nommé 'assist' n'est trouvé

Out[16]= $Failed

What should I do?

Regards,

Claude

3 Replies

The error you are getting indicates that the package you try to use is / has not been installed.

Package installation from within RLink is currently possible only on Windows. Moreover, for Mac and Linux, and if you want to install packages you will generally need to use external R installation with RLink, rather than the one that comes bundled with it.

What this means is that you will have to first install an external version of R separately. Then you can install the packages you need, using R console / command prompt, that comes with that R installation. Then you should be able to use RLink with that external R and use the R packages you need.

If you are on Windows, I would still recommend to use external R installation, since the one that comes with RLink is pretty old.

Hi Leonid,

"assist" works under R installed on my machine:

enter image description here

It seems the problem stems from the R version of RLink; nevertheless, introducing (in my case)

InstallR["RHomeLocation" -> "C:/Program Files/R/R-3.1.2"]

this problem can be solved (I think).

Thanks a lot,

Claude

Claude,

Glad if that worked for you.

Leonid

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract