Message Boards Message Boards

GROUPS:

3D Graphics with Metal rendering problems

Posted 16 days ago
293 Views
|
6 Replies
|
5 Total Likes
|

I've been exploring the new 12.1 features. However, there's seems to be a bug on rendering 3D graphics in MacOS. The graphics are not being shaded correctly, they appear too dim.

I tested on my Windows 10 machine and the problem doesn't appear there.

Plot3D[Sin[x y], {x, 0, 3}, {y, 0, 3}, 
 ColorFunction -> "BlueGreenYellow", ImageSize -> 720]

On Windows:

Result on Windows

On Mac:

Result on Mac

Any workarounds in the meanwhile?

6 Replies

I have a Mac with Mojave 10.14.6, and detect no difference in the rendering of that surface between 12.0 and 12.1. Perhaps Metal has changed with Catalina?

Posted 16 days ago

Lombardo,

I've not been able to reproduce this on my MacBook Pro. Graphics look as expected all around. Are you using an external monitor? Are there any other things that might make your setup unique, outside of using just the default laptop monitor?

You might be able to workaround this with

SetOptions[$FrontEnd, RenderingOptions -> {"3DRenderingEngine" -> "OpenGL"}]

This can be reset back to its default value with the following, as needed

SetOptions[$FrontEnd, RenderingOptions -> {"3DRenderingEngine" -> "Automatic"}]

Hi Kyle, thanks for the quick reply.

I can confirm the problem only occurs with an external monitor connected. Here are my Mac computer specs

Environment specs

Quite a strange bug. Using Lighting -> {{"Ambient", White}} gives the expected result. Changing the rendering engine to OpenGL SetOptions[$FrontEnd, RenderingOptions -> {"3DRenderingEngine" -> "OpenGL"}] also fixed the issue.

I'm happy to give more information is required. Thanks for the workaround, I've found Mesa works best in the meanwhile.

Posted 16 days ago

Thanks for the details!

Posted 15 days ago

I have the same bug when the "PreferredGPU" option is "Discrete" value in my Macbook pro 16'' with eGPU.So, You can try to change the "PreferredGPU" value.enter image description here

enter image description here

I had the same problem with Mathematica 12.1, my setup: MacBook Pro 16-inch 2019, Catalina 10.15.4, AMD Radeon Pro 5500M 8 GB, Intel UHD Graphics 630 1536 MB, external monitor LG 27UK850. Graphics Ok without the monitor, darker with the monitor. Solution seems to be Global Preferences >> Rendering Options >> 3DRenderingEngine = "OpenGL" or "Mesa"; the problem seems to be with "Metal" (which seems to be the default choice for "Automatic").

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract