Message Boards Message Boards

GROUPS:

2D expression input corrupted in 12.1

Posted 3 months ago
660 Views
|
6 Replies
|
1 Total Likes
|

Hi all

I've just upgraded to 12.1 on my MacOs Catalina and ctrl+^ and ctrl+2 do not work anymore.

I'm using an Italian keyboard, but switching to US doesn't help

Any similar experience? Any suggestion?

6 Replies

They work on my Mac with Mojave and 12.1, with International English keyboard. You can check the key combination in the menu Insert>Typesetting>Superscript or Insert>Typesetting>Superscript>Radical

Those 2D input shortcuts work perfectly with Mathematica 12.1 on my iMac under macOS Catalina (10.15.3).

Posted 3 months ago

Thanks Murray. Let's see what Wolfram says...

Stefano

Posted 3 months ago

They work on my Macbook pro 16'' with macOS 10.15.3

Posted 3 months ago

I have the very same problem. MacBook Pro '15, Italian Keyboard. Already with the older version subscript would not be doable anymore. Now also exponentiation. It is extremely annoying. Since with international/English keyboards it seems to work, the problem is how to tell Mathematica that it's using the wrong shortcuts. Indeed, if I use ctrl+6 I do get exponentiation because that's where the ^ sign is in the English keyboard.

Posted 3 months ago

Hi Juri,

This is what I got from Wolfram. Looks a bit invasive. I found a few work around, so I did not try

In bocca al lupo

Thank you for contacting Wolfram Technical Support. I understand the exponent keyboard shortcut is not working.

While I am having trouble reproducing the issue on my end, most common problems with Mathematica can be fixed by resetting it to its default configuration. This involves deleting or renaming some directories that contain the user preferences. Their location depends on what operating system you are running and on a Mac these are:

* /Library/Mathematica
* ~/Library/Mathematica
* ~/Library/Caches/Wolfram
* ~/Library/Wolfram

Some of these files may be hidden on your computer. You can navigate to hidden folders by opening the Finder application, pressing Command+Shift+G on your keyboard, and then typing the path to them (as ~/Library/Mathematica/ to open the Mathematica folder in ~/Library)

Further details on this process can be found here: https://support.wolfram.com/12464. Please note that if you will be deleting these directories, you should back up any custom files you have saved to them. Mathematica will recreate these folders with the default files when it is started. You also might need to reactivate Mathematica after this procedure.

Please let me know if I have missed any part of the problem or if the issue persists.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract