Message Boards Message Boards

14 Replies
2 Total Likes
View groups...
Share this post:

Wolfram Alpha: ODE step-by-step gets blacked out?

Posted 11 years ago
Sometimes when I try to solve an ODE in Wolfram Alpha, the step-by-step solution gets blacked out. Why does this keep happening?

POSTED BY: Noe Brito
14 Replies

Dear all, have you tried contacting Wolfram|Alpha team directly? This is just a forum and we have passed information to the Wolfram|Alpha team and they are aware. If you wish to discuss your particular issues and time-frames you best talk to the team directly following the above link as this Community has no further information. Please understand communicating with team directly will get things resolved much quicker. Once you establish the contact with the team you can ask them for updates on the issue.

POSTED BY: Moderation Team

Still Having this issue, on Mac OS X with safari and chrome.

POSTED BY: Robert saunders
Posted 9 years ago

I get the same bug on Mac Firefox, Chrome, and Safari. It happens when displaying ODE step-by-step solutions using undetermined coefficients and variation of parameters. So far happens with every ODE I try. ODE Laplace transform solutions do not cause the bug.

enter image description here

POSTED BY: Warren Whipple

2 years from the original post and I'm having the same issue, with the undetermined coefficients method of solving ODEs. It happens in Chrome and Internet Explorer. Running Windows 7 Pro 64 bit. Has Wolfram found any solutions to this yet? enter image description here

POSTED BY: Justin Beyerlin
Posted 9 years ago


The problem still exists and the work around works. I'm in chrome on windows 7.


POSTED BY: Jw Pepper
Posted 10 years ago

I am experiencing the same thing! Very frustrating. However, the 'customize and save image' button also works in FireFox. Thanks Liam Stevens!

POSTED BY: jonathan miller
Posted 10 years ago

Bug still exists. Been getting these all day. This is the raw PNG I get from right,click, saving:

Customize & Save Image saves the day by fixing the colors

This is the raw PNG I get from right,click, saving

POSTED BY: Nebi Cicek
Posted 11 years ago
Just want to chime in here and say I had the same problem, and as I'm using it for free it was particularly infuriating since I didn't know what was going wrong and I wasn't able to re-try different inputs.  I work at a university and it wouldn't be a big deal for my lab to subscribe me to the Pro service but I certainly can't do that as long as this doesn't work.  I note though that if you reveal one step at a time, it will show most of the steps, but when you hit one near the end, then suddenly everything gets blacked out (I want to see those steps though!).  My input to produce this was

y''(t) + a*y'(t) + b*y(t) = x(t)

NB, this equation did not have a problem:

y''(t) + a*y'(t) + y(t) = x(t)

The bug appears to arise where the pathways for solving these two equations diverge.
POSTED BY: Matt Phililps
Thank you for letting us know about this. I've forwarded this information to the developers working on Wolfram|Alpha to ensure that they are aware of the issue. 
POSTED BY: Sean Clarke
Posted 9 years ago

Hey man, when is this going to get fixed? I've come back to this thread multiple times now over the past year.

To all others who NEED this to be working, if you use the wolfram alpha app on your smartphone, you will not receive this bug.

POSTED BY: Ryan Bonomo
Posted 11 years ago
I've had the same issue, it only seems to happen with the method of undetermined coefficients. A way around it that I have found seems to work fairly consistently is to click the "Customize and Save Image" button, which displays the working without blacking it out.

Bear in mind this works with Google Chrome, it may not work with Firefox and/or IE11 (haven't tested).

It is just a workaround though, hopefully this gets fixed.
POSTED BY: Liam Stevens
Posted 11 years ago
Wow, great find Liam Stevens! That will do for now. Hopefully it gets figured out soon!
POSTED BY: Noe Brito
Are you seeing this in your web browser or in Mathematica?

What operating system and web browser are you using? If possible, would it be possible to see a screen-shot of the problem? 

Does this problem happen when you try different web browsers?
POSTED BY: Sean Clarke
Posted 11 years ago
Hey there, thanks for the reply.

It happens in the web browser. I am using Internet Explorer 11. I tried it in Firefox and the same thing happens. I'm using Windows 8.1.

Note that it doesn't seem to happen ALL THE TIME. Just intermittently. It's just pretty annoing since I am paying for the service and I constantly have this problem.

Here is a screenshot (above).
POSTED BY: Noe Brito
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract