Message Boards Message Boards


Why did V 12.1 Change all the notebook sizes and fonts?

Posted 1 year ago
4 Replies
1 Total Likes

I installed Mathematica Version 12.1 and there is a huge change in its look. All the notebooks and palettes are HUGE. And yet if I adjust them to 75% or 50% magnification some of the important text becomes too small to read. The entire appearance that I carefully designed with style sheets and that has worked for many previous versions has been destroyed.

I believe that a magnification of 100% should be the standard and should work for most people.

Is there some simple option that can be fixed to restore the previous appearance?

If it's a deliberate change made by Wolfram, what right is there to do that?

Also I still have V12.0 on my computer, but I can't open any notebooks with it.

4 Replies
Posted 1 year ago

I believe Mathematica 12.1 on windows now supports display with high dpi's.

Perhaps that causing your troubles. I had some issues running 12 and 12.1 so I removed the old version. It's weird that 12 does not open your notebooks. Perhaps log a call with support?

I can confirm the change for Windows appearance in Mathematica 12.1 with, for example, your PresentationsPalette and Presentations stylesheet. Their windows are too large, but reducing their magnification makes the font size too small.

That is true, at least, for Windows running as a virtual machine (in Parallels Desktop) on my 27" iMac. But I don't believe that using the virtual machine makes any difference here: Windows is using the native resolution of my Mac.

Usually I'm running Mathematica 12.1 directly on the iMac, and there the palette sizes and stylesheets seem OK.

Not sure why 12.0 won't open notebooks after you installed 12.1. During pre-release testing of 12.1, I was able to open notebooks in either one (but of course getting the pop-up cautions if I tried to open in 12.0 a notebook created in 12.1).

Can you open 12.0 and create a new notebook there? If so, then save it, restart 12.0, and open that same notebook?

One suggestion of remotely possible use: do you have set the preference in both to use version-specific preferences? (Not sure if this would make any difference, just trying to think of what could be wrong.)

There are a number of issues. Support recommended doing a clean start and changing some options. Even when V12.1 is uninstalled there are features in V12.0 that no longer work, such as creating a new notebook in a folder using the right click context menu. In any case, support is going to look at it much more intensely this afternoon so we'll see how it works out.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract