Message Boards Message Boards

GROUPS:

Why WolframModel Fails to Work on my Mathematica?

Posted 2 months ago
516 Views
|
2 Replies
|
0 Total Likes
|

When I run this line of code

ResourceFunction["WolframModel"][{{x, y}, {x, z}} -> {{x, z}, {x, w}, {y, w}, {z, w}}, {{0, 0}, {0, 
   0}}, 5, "StatesPlotsList"]

on Wolfram Cloud, it works fine. But when I run it in my Mathematica, it says

Get::noopen: Cannot open SetReplace$0$2$116`.

And returns the original input:

ResourceFunction[
 "WolframModel"][{{x, y}, {x, z}} -> {{x, z}, {x, w}, {y, w}, {z, 
    w}}, {{0, 0}, {0, 0}}, 5, "StatesPlotsList"]

I tried the function CloudConnect[] and I successfully connected to Wolfram Cloud, but still it does not work. Does anybody know what's going on with this?

Thank you so much!!!

2 Replies
Posted 2 months ago

Can you try running the following?

PacletInstall["SetReplace"];
<<SetReplace`

Then you should be able to use WolframModel directly without wrapping it in ResourceFunction, i.e.,

WolframModel[{{x, y}, {x, z}} -> {{x, z}, {x, w}, {y, w}, {z, w}}, {{0, 0}, {0,
    0}}, 5, "StatesPlotsList"]

Note also, it requires Mathematica 12.1+ to run.

Posted 2 months ago

Thank you! Now it works!

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract