Message Boards Message Boards

4 Replies
1 Total Likes
View groups...
Share this post:

Cursor disappears in Mathematica 9.01

Posted 11 years ago
When entering an equation via the block templates from the Writing or Basic Math Assistant, the cursor almost always disappears.  This leaves me guessing as to what block actually has focus.  Also I cannot select a block by clicking it.  Is there an alternative editor available - can a third-party equation editor be used in Mathematica?  This appears to be a paint problem.  I have noticed this issue with Mathematica 8, 9 and 9.01.
POSTED BY: Doug Kimzey
4 Replies
When Mathematica develops a strange behavior, it is worth resetting start-up files in case one had been damaged.

On any platform, some can be reset by holding down the SHIFT key as Mathematica launches.
The bigger hammer is platform dependent.  See
POSTED BY: Bruce Miller
I have the same problem on one of my sheets (using the default stylesheet). I started from scratch and re-wrote that sheet, still using the default stylesheet; and, the cursor is acting normally. So, it is not endemic to Mathematica, but must be in in that one sheet. I cannot find what's different about the sheet that is making it behave so. 
By the way, this is on a Mac Pro running Mountain Lion, 10.7.5. 
POSTED BY: Uday Shankar
Have you tried ShowCursorTracker as described in ?
POSTED BY: Udo Krause
Udo - Thanks very much for your reply.  I tried the ShowCursorTracker command but this has no effect.  The cursor disappears whenever using the block templates from any pallet - there is no indication of what block has the focus.  Also the focus cannot be set to a block by clicking a block.
POSTED BY: Doug Kimzey
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract