Message Boards Message Boards


Manipulate function in my CDF not working in Player

Posted 1 month ago
3 Replies
0 Total Likes

Hi, I am very new to Mathematica and am helping a friend with his invention. The notebook below was created with Mathematica 12 Home Edition on Windows 10. I am trying to share it with my friend by sending him the cdf and asking him to load it in the Player. Unfortunately the Manipulate function at the end only displays an empty plot with an x and y axis when I open it in the Player myself. What am I doing wrong?

Thank you, Christoph Wagner

3 Replies

Try adding the SaveDefinitions->True option to the Manipulate.

BTW, please don't put you code in hidden cells when asking here.

Posted 22 days ago

I have exactly the same problem. I tried SaveDefinitions->True and in one plot it worked, and in the other plot I got "Initialization timed out >>". I don't care how long it takes so long as it eventually generates the plot. I had to ask for help on how to generate the plot - I have , PlotRange -> All, PlotPoints -> 5000 to ensure no aliasing problems in the plot. Hopefully this is trivial! Thanks. Mike Rosing

Posted 22 days ago

Found the answer here: I added SynchronousInitialization -> False in addition to SaveDefinitions. It takes about 45 seconds to initialize and then the Manipulate plots and works fine. So it was trivial!

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract