Message Boards Message Boards

9 Replies
8 Total Likes
View groups...
Share this post:

How can I modify the shortcut CTRL + = to enter an Entity?

Posted 10 years ago


this question is related to this one here. I have a German keyboard and there is no "=" key, so I can't use the shortcut "CTRL" + "=" to enter an Entity[]. How can I replace this shortcut with e.g. "CTRL" + "0", which is the closest to "CTRL" + "=", as "=" equals "SHIFT" + "0"? Is there any option in the preferences?


(it's related to Mathematica 10)

9 Replies

The short cut has been changed in the meanwhile to ctrl + * I have a German keyboard and Version 13.2 running.

I guess nothing beats a keyboard with a US layout for programming. :)

I tried plenty of AutoHotKey scripts to enter Ctrl+= — but to no avail. Maybe someone has a nice AutoHotKey snippet for me that will do the trick?

I have the same problem with Mathematica v.12.0 running on Windows 10. The only solution I found is to **Insert** -> **Insert Free-form Input**

The Portuguese keyboard has the same layout problem (CTRL + SHIFT + 0).

I can confirm that this key combination doesn't work on Mathematica, and that my windows is not using the CTRL + SHIFT combination to switch input languages or keyboard (it doesn't seem to be using it for anything).

With the above in consideration, and considering that:

  • 2 versions later the inline natural input is more and more of relevance on the entity framework,
  • the web interface seems to suffer from the same problem...

...I believe that a better solution should be implemented as alternative to asking (many) international users to reconfigure the menu configuration file just after first install, update, etc... (don't even know how to do that on the cloud interface..., and the documentation doesn't seem to mention inline free-form input on the shortcuts page)

POSTED BY: Pedro Fonseca

Thanks a lot to Andreas for putting forward this problem and to Ilian for solving it. I had the same problem with a Norwegian keyboard and accepted it didn't work in the previous versions. But now it has become a more important feature in version 10 and short cuts for free-form input should be available on all key boards. The quick fix is registered and appreciated, but a real fix is needed next time.

POSTED BY: Arne Eide

Hi Ilian, thanks for hint! I have found the file and modified it, but CTRL + 0 is already used:

MenuItem["End &Inline Cell", "MoveNextCell", MenuKey["0", Modifiers->{"Control"}]]

So I modified it using "F8" instead. It works as expected. Thanks!

MenuItem["Inline Free-form Input",
       MenuKey["F8", Modifiers->{}], MenuEvaluator -> "Local"]

insert menu

The shortcut can be changed by modifying the file

 FileNameJoin[{$InstallationDirectory, "SystemFiles", "FrontEnd", "TextResources", 
      Switch[$OperatingSystem, "Windows", "Windows", "MacOSX", "Macintosh", "Unix", "X"], ""}]

Specifically, look for

MenuItem["Inline Free-form Input",
         MenuKey["=", Modifiers->{"Control"}], MenuEvaluator -> "Local"]
POSTED BY: Ilian Gachevski

CTRL-SHIFT-0 should work. On Windows, CTRL-SHIFT is sometimes used to switch input languages or keyboard layouts, so this may need to be changed in the OS preferences.

POSTED BY: Ilian Gachevski

Hi, CTRL + SHIFT + 0 doesn't work; this was my first try. Any other ideas?

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract