Message Boards Message Boards

2
|
20117 Views
|
21 Replies
|
18 Total Likes
View groups...
Share
Share this post:

WebMathematica for Mathematica V10 (Yes!)

Posted 10 years ago

Does anyone know when webMathematica will be updated to work with version 10?

POSTED BY: Rodrigo Murta
21 Replies

1024, 20480, 768

seems to be needed for me (Windows 10, Mathematica 10.4.0 and newer)

POSTED BY: Rolf Mertig

And it also works fine for 10.1 by adding these lines to MSPConfiguration.xml :

Windows:

<KernelExecutable>
        C:\Program Files\Wolfram Research\Mathematica\10.1\MathKernel.exe
</KernelExecutable>

<FrontEndExecutable>
        C:\Program Files\Wolfram Research\Mathematica\10.1\Mathematica.exe
</FrontEndExecutable>

Linux:

<KernelExecutable>
      /usr/local/Wolfram/Mathematica/10.1/Executables/MathKernel
</KernelExecutable>

<FrontEndExecutable>
      /usr/local/Wolfram/Mathematica/10.1/Executables/Mathematica
</FrontEndExecutable>
POSTED BY: Rolf Mertig

Now webMathematica V3.3 has official support to Mathematica V10!

Check: http://www.wolfram.com/products/webmathematica/

POSTED BY: Rodrigo Murta

Our documentation for webM installation for Linux can be found here:

Here are some things that I've found to be quite useful:

  1. give the tomcat user a shell. That way, you can log in to your machine as that user and test things out yourself. Some possible issues that you can uncover this way are mathpass file issues and front end issues\
  2. As Rodrigo says, the FrontEnd needs to work in order for any images (plots included) to be generated. So you need to allow the tomcat user to have access to a display. I'd recommend using a vncserver for this. You will need to set the FrontEndLaunch flags in our MSPConfiguration.xml file. We have examples in the documentation; my setting is "-display chadsLinux:1 -nogui -geometry 1000x500+24+24".
  3. For testing purposes, try logging in to a terminal as the tomcat user and launching Mathematica in your vnc display. At the terminal prompt, type '\path\to\Mathematica -display [your machine]:[the display number]'. In a vncviewer set to that display, check to see that it launched correctly. Try some evaluations in a notebook
  4. Tomcat setup is really the key issue for installation. I've found that default installations using apt-get (Ubuntu) and yum (Red Hat) both work nicely. If you have never used tomcat previously, those are a great starting point.

If you have any other questions, please contact our tech support. Have fun!

POSTED BY: Chad Knutson
Posted 10 years ago

Anybody get this to work for Linux? Steps would be most helpful.

POSTED BY: Caitlin Ramsey

I don't have the steps, but I have success in make it work in RedHat. It was not easy to make front end to work. Front end instance is needed for make plots or file export to work.

POSTED BY: Rodrigo Murta

Window 7 64bit Mathematica 10 64bit Mathematica 9 64bit

I'll update here any interesting news about working or not working examples.

I'm very glad to hear that it works, Roberto!

Could you share the version of Windows that you're using?

POSTED BY: Chad Knutson

Well, finally it works!!! I used a bigger value as third argument, exactly 20480 instead of 1024. The strange thing is that it doesn't work without the third parameter. However, now it works and I'm very grateful to you for the help. :-)

Nice!... One more WebMathematica in V10.

POSTED BY: Rodrigo Murta

yes after each change in the registry I rebooted the machine, and I also tried to leave it blank, with the same (negative) result. I'll try a bigger value and then also the JLink suggestion, let you know.

I can't remember what the exact memory usage of the front end is. It may be slightly greater than 1024 (I left my 3rd entry blank).

One dumb question for you: did you reboot the machine after editing the registry?

Another possible issue is the JLink native directory. You can try specifying it explicitly (make sure to edit if you have a different location:

<JLinkNativeLibraryDirectory>
C:\Program Files\Wolfram Research\Mathematica\10.0\SystemFiles\Links\JLink\SystemFiles\Libraries\Windows-x86-64
</JLinkNativeLibraryDirectory>
POSTED BY: Chad Knutson

I have done exactly the steps you mentioned. Now, if I change the path to 9.0 it works, when I change to 10.0 it doesn't. This is the corresponding code in MSPConfiguration.xml

<KernelPool> <KernelPoolName>General</KernelPoolName> <URLPattern>/*</URLPattern> </KernelPool>

<KernelExecutable>C:\Program Files\Wolfram Research\Mathematica\10.0\MathKernel.exe</KernelExecutable>

And this is the register key value

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows SharedSection=1024,20480,1024 Windows=On SubSystemType=Windows ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3 ServerDll=winsrv:ConServerDllInitialization,2 ServerDll=sxssrv,4 ProfileControl=Off MaxRequestThreads=16

Where I'm wrong? Thanks again

No, it want to work! Any further suggestion?

Unfortunately, it doen't work for me. I tried deleting the value at all, as suggested by Rodrigo and then putting an hig value, as suggested in the MS support page (for instance 1024 or higher). It still gives the same error. I'm still investigating, I'll post any news. Thanks again

Yes. For Windows I did this to make de V10 kernel to work:

  1. First install Mathematica 9
  2. Make WebMathematica work on 9
  3. Install version 10 and redirect to Mathematica 10 kernel in MSPConfiguration.xml file.
  4. If last step work, now you can uninstall version 9.

And then, to make Graphics work (front end dependent expressions), I need to change windows regedit.

PS: in MAC, it didn't worked with JAVA 8, I needed to downgrade into java 7.

POSTED BY: Rodrigo Murta

Hi there, thanks a lot for both answers. I'm going to try right now and let you know.

Mathematica 10 is not officially supported by webMathematica, but it can be made to work reasonably well.

Roberto, I'm guessing that you are using a Windows machine? If that's true, then the problem is that Mathematica 10's front end uses more memory than allowed by the default desktop heap setting for noninteractive users.

You can read more about it here: [http://support.microsoft.com/kb/2102398][1]

The short answer is that you can edit the registry to increase this value. Then the front end should work fine in webM.

POSTED BY: Chad Knutson

Yes.. it works! It's just change the path.

PS:Do not forget that it's commented in the standard MSPConfiguracion.xml file. It's not enough to change the name.

POSTED BY: Rodrigo Murta

Hi Rodrigo, are you working with webMathematica and Math10? I'm not able to run it. For each example in the documentation I get the following error: FrontEndError: ExportString failed:\

Notebook[{Cell[BoxData[RowBox[{FractionBox[x, 2], -,\

RowBox[{FractionBox[1, 4], , RowBox[{Sin, [, RowBox[{2, , x}],\

]}]}]}]], Output, ShowCellBracket -> False, CellMargins -> {{0, 0}, {0,\

0}}, PageWidth -> 800]}, WindowSize -> 900]

I changed the configuration file adding the path to Mathematica 10.0 and it works, indeed the following "< msp:evaluate >$Version< /msp:evaluate >" works fine. Please, let me know if you have any hint. Thanks in advance. Roberto

Hi Roberto, Can you try this:

The suggestion is to to increase the desktop heap configuration via the registry.

Windows limits the amount of memory allocated to noninteractive users (such as kernels launched by webMathematica). When these kernels need to perform a calculation that requires the front end (example render a plot), the memory allocation setting may prevent the launching of the front end. To solve this problem, edit the registry.

HKEYLOCALMACHINE\System\CurrentControlSet\Control\Session Manager\SubSystems\Windows %SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows SharedSection=1024,3072,512 Windows=On SubSystemType=Windows ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3 ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off MaxRequestThreads=16 In the "SharedSection", the 3rd number can be deleted (512 above). This allows noninteractive users the same amount of memory as interactive users.

This is also documented under the Increasing Desktop Heap section at http://support.microsoft.com/kb/2102398

We tested this fix on "one" system we had available for this purpose and found success.

Let me know if this helps.

Let me know if worked for you too.

POSTED BY: Rodrigo Murta
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract