Message Boards Message Boards

GROUPS:

How to turn off raise on click for Mathematica notebook window?

Posted 9 years ago
1085 Views
|
0 Replies
|
1 Total Likes
|

The window behaviour for Mathematica has changed in Version 10. It now seems to be the case that clicking within a notebook window will bring that window to the top, regardless of the settings I have set for window management. Mathematica 10 is the only application that I know of that does not respect my window management settings.

In versions 7 and 8 (and perhaps 9?) I was able to have any Xwindow on top of a Mathematica notebook while still being able to have the Notebook window take focus (eg. be able to type into the Notebook without that window coming to the top).

This is not just a problem for Xwindows of other applications --- it applies also to those opened by Mathematica.
For example, if I open a documentation window for a function (say by F1 on a function name) then the documentation window becomes obscured by the Notebook window as soon as I start typing into the Notebook. Similarly for the small window opened by Find.

I am using the KDE desktop on an up-to-date Debian stable system. I have Mathematica versions 7 , 8, and 10 all running on the same system, so there is no doubt that window behaviour for Mathematica has changed in Version 10.

Is there some way to turn off raise on click, or is this an interface bug ?
Does anyone have a Mathematica 10 that does not raise on click?

POSTED BY: Andrew Norton
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract