Message Boards Message Boards

0
|
11917 Views
|
3 Replies
|
0 Total Likes
View groups...
Share
Share this post:
GROUPS:

Prompt for Mathematica 10 Activation Code when Debugging in Workbench 3.0

Posted 10 years ago

I have a project that was started in Workbench 3.0. I was trying to go into a debug session and a dialog asking for the Mathematica 10 Activation code appeared. I entered my activation key and received a dialog that said communication was successful but the incorrect password was returned.

POSTED BY: Doug Kimzey
3 Replies

A few notes on what I am seeing. This is very likely a configuration issue with my project.

  • Breakpoints in modules that you are trying to debug are ignored if the call is made from a nb. The Debug session will produce a "Initialization Complete" message in the Console Window. But the perspective will not switch to the Debug view. No breakpoints will be triggered.

  • Create a .m file with the same calls as those in the notebook -the perspective now switches to Debug and breakpoints are now hit.

  • In my case, the Needs[] must include full paths to each .m file. Setting the paths is resources does not affect this.

  • When trying to switch to source code in a different .m file, the following error occurs

"An internal error occurred during: "Debug Source Lookup".java.lang.NullPointerException"

  • File | Restart in Workbench 3 is hit or miss.

  • Renaming a module in a .m file. Numerous errors appear in the Problems tab. Shut down Workbench and re-start. All problems gone.

  • Right click code in a scrapbook file and select Debug As produces the following error message: "The selected file is not a Wolfram notebook or scrapbook file. Please make sure that a file with an extension .nb or .mscrapbook is selected and try the run again."

  • Have not been able to start and complete a local debug session in Workbench 3.0 using Mathematica 10 as the engine. I have not tried this on the Programming Cloud (I have some heavy security requirements that prohibit exposing any client data on The Internet - even when encrypted).

  • One additional item - I tried switching from a scrapbook to a notebook. When the debug session is launched, Mathematica 10 is launched and the specified notebook is loaded. When the code for the notebook is executed, the code in the main project .m file is executed (this looks like a load order behaviour). I have tried to put breakpoints in the project .m file - but no joy. Trace and other statements show code called from the project .m file is executed but all breakpoints are ignored (even in cases where the perspective switches to the Debug view).

  • Error message in Mathematica after last debug attempt:

"JavaNew::fail: Error calling constructor for class com.wolfram.eclipse.MEET.debug.MathematicaStackFrame. >>"

  • Odd behavior when stepping into a function:

"Problem Occurred - Debug source lookup has encountered a problem. - An internal error occurred during "Debug Source Lookup." Details: An internal error occurred during: :Debug Source Lookup". Path must include project and resource name: /TypeSystemLoader.m

POSTED BY: Doug Kimzey

What happens when you run Mathematica itself? Please check that you are running the copy of Mathematica that Workbench is pointing to.

If you are having trouble activation your copy of Mathematica, please contact customer service:

http://www.wolfram.com/support/contact/

POSTED BY: Sean Clarke

Hi Sean,

Mathematica 10 launches without problem or prompts for the activation code. This is the version I am pointing to in Workbench 3.0. I have contacted support.

-Doug

POSTED BY: Doug Kimzey
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract