Message Boards Message Boards

0
|
18023 Views
|
11 Replies
|
0 Total Likes
View groups...
Share
Share this post:
GROUPS:

Failed to Detect Compiler Version

Posted 10 years ago

Has anyone received this error (see attached screen shot) when trying to select the appropriate compiler within the global options of System Modeler 4.0? I am running Win8.1 (x64). This error is preventing me from doing any work with System Modeler so any thoughts/suggestions would be appreciated. Let me know if I need to provide any additional information. Thank you.

Attachments:
POSTED BY: Bruce Venne
11 Replies
Posted 10 years ago

I was responding to the query related to the error captured in your screen shot. In my case it turned out to be a %Path% problem (missing C:\Windows\System32). Adding “C:\Windows\System32” back to %Path% fixed the problem. %Path% is, of course, the Windows Environment Variable.

Please refer to http://stackoverflow.com/questions/3461275/vs2010-command-prompt-gives-error-cannot-determine-the-location-of-the-vs-comm for further details. Fulvio

POSTED BY: Fulvio Spagna
Posted 10 years ago

I understand now, thank you. I checked my Path variable in the Environment Variables settings and "C:\Windows\system32" (note the lower-case "s") was listed there. I modified it to "C:\Windows\System32" as I wasn't sure if that made a difference or not. But now I'm getting a completely different error message when starting System Modeler (see below). I hate to get side-tracked with a completely different error, but this particular one will not even let me start the program for whatever reason.

enter image description here

POSTED BY: Bruce Venne
Posted 10 years ago

Hi Bruce

I had a similar issue. As it turns out the %Path% variable was corrupted and C:\Windows\System32 had been removed. Adding it back took care of the problem.

Fulvio

POSTED BY: Fulvio Spagna
Posted 10 years ago

Thank you for the response Fulvio, could you expand on that some more? I'm not quite sure what you are referring to.

POSTED BY: Bruce Venne

Don't you have any other choices in the Select compiler combo box (see attached image)? SystemModeler should auto detect your visual studio installation and present it as a choice there.

There is a bug that in 4.0 that if you select Custom and then browse for the directory to find vsvars32.bat it will always say that it fails to detect compiler version. However, it should work to manually select the compiler version and then OK. You can verify that it worked by trying to simulate IntroductoryExamples.HelloWorld for example.

Also, note that the "Path to vsvars32.bat" should be the path to the directory where vsvars32.bat is located. So in your second example the correct path is C:\ProgramFiles (x86)\Microsoft Visual Studio 11.0\Common7\Tools (no \vsvars32.bat at the end).

Select compiler combo box

POSTED BY: Otto Tronarp
Posted 10 years ago

Hello Otto, thank you for the reply. I tried using the default compiler selection (see below) but I still get the verification failed (No log file) error. I only have that or the "custom" option. Do I need to have any other Microsoft packages installed for this to work properly?

Regarding your note on the file path, a suggestion was made for me to try the full path including the file name "vsvars32.bat" so I tried that. As I suspected though, it also did not work. I changed it back to the standard "Tools" directory. Any other thoughts on this? A very odd problem.

Attachments:
POSTED BY: Bruce Venne
Posted 10 years ago

Hi Bruce, Have you tried to select the compiler "Visual Studio 2013" from the "Select compiler" drop down menu? Which version of Visual studio do you have installed?

POSTED BY: Johan Rhodin
Posted 10 years ago

Thanks for the reply Johan. Yes I've tried using the default selection for Visual Studio but it fails to verify (screen shot attached). So I tried uninstalling VS 2013 and installed VS 2012 Pro. Same error. For whatever reason, the software can't seem to find the "vsvars32.bat" file even though I've confirmed it to be in the proper directory. Any other thoughts? Could this be an issue of 32 vs 64-bit compatibility?

Attachments:
POSTED BY: Bruce Venne
Posted 10 years ago

I see. One thing you can do is to re-install SystemModeler. It will try to auto-detect the compiler and that might work.

POSTED BY: Johan Rhodin
Posted 10 years ago

Thanks for the suggestion. I did try re-installing both System Modeler and Visual Studio 2012/2013 several times to no avail. System Modeler does detect that I have VS 2012 installed as it is an option in the drop-down menu (see my screen shot below). However, the verification of said compiler continues to fail for one reason or another. As a speculation on my part, I would say it has to do with something relating to how permissions are handled within Windows 8.1. However, the verification failure notice is still puzzling to me because what "log file" is it trying to locate? Do I need to create a log file in a specific directory because one was not properly created during installation? Just some additional thoughts on my end.

POSTED BY: Bruce Venne

As a speculation on my part, I would say it has to do with something relating to how permissions are handled within Windows 8.1.

You might be right, I managed to get the same error if I removed the .bat file that is called to do the compilation. The script is bin\CompileVC9.bat (located in the SystemModeler installation directory usually C:\Program Files (x86)\Wolfram Research\SystemModeler 4.0), check if you have permissions to execute that bat file.

POSTED BY: Otto Tronarp
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract