Message Boards Message Boards

0
|
9414 Views
|
6 Replies
|
3 Total Likes
View groups...
Share
Share this post:

WolframScript problem

Posted 10 years ago

Hi,

I'm trying out Wolfram Language on my Raspberry Pi.

I did upgrade to 10.0

Using the examples on http://reference.wolfram.com/language/tutorial/WolframLanguageScripts.html I created the following script:

#!/usr/local/bin/WolframScript -script

Integrate[Sin[x],x]

I did chmod 755 * to the directory where the script was saved as example1.m

When running the script from the commandline with ./example1.m I get this error message:

bash: ./example1.m: /usr/local/bin/WolframScript: bad interpreter: No such file or directory

Please assist what I'm doing wrong :)

Thanks Nico

6 Replies

It seems WolframScript hasn't been included (yet) in the Raspberry Pi release, however one may still run scripts on the command line using

$ wolfram -script myscript.wl
POSTED BY: Ilian Gachevski

True, this guy Kofler Raspberry Pi says the same thing ...

Kofler pic

... update your documentation, please!

POSTED BY: Udo Krause

Hi,

Thanks for the response. Much appreciated!

I did the following:

I upgraded to the latest version of Raspian. This includes Wolfram/Mathematica 10 by default.

The WolframScript command is still not present - tested all the proposed ways. Including the find command in the last post.

Regards Nico

Hi,

I did the ls as requested - there is no such file.

I use the previous Raspbian, and did the upgrade with sudo apt-get update/upgrade around 2 weeks ago to upgrade to Wolfram/Mathematica 10.

I tried sudo apt-get install WolframScript - no such package was found.

Thanks Nico

I don't have a Raspberry Pi, but they recommend to do

sudo apt-get update
sudo apt-get install wolfram-engine

it should somehow go with the so called wolfram-engine. Without installing something WolframLanguageScripts nothing will happen, WolframScript, you can also do at the prompt

$ find  / -type f -name "*olfram*cript" -print 2>/dev/null

to find it on your machine with the bash, if it is already installed.

POSTED BY: Udo Krause

/usr/local/bin/WolframScript: bad interpreter: No such file or directory

That means that the shell (bash) does not find the file /usr/local/bin/WolframScript or that the shell is not allowed to execute it.

What do you see if you type

$ ls -al /usr/local/bin/WolframScript

at the prompt? Did you install WolframScript?

POSTED BY: Udo Krause
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract