Message Boards Message Boards

0
|
10410 Views
|
4 Replies
|
1 Total Likes
View groups...
Share
Share this post:

Having issues opening a single *.nb file

Hello, This is the first time I have experienced this problem and cannot find anything else online like my issue. I use Mathematica for a class at University. I write down my homework assignments in the notebook I use to take notes for that lecture. I have no problem opening any other -.nb files except for the one that has my homework assignment for this evening written in it. When I open it, it just opens the small exit window with the options "New Notebook," "Open...," and "Exit." I also get an error message: This file contains potentially unsafe dynamic content I choose "Enable Dynamics," but nothing happens. I have tried every route for opening a file, but this always is the output.

Does anyone know how to get my notebook to open?

I have an image of my screen. You can see I can open other files, but when I open the one I have titled "10-8.nb," I get the top screen... I have an image of my screen. You can see I can open other files, but when I open the one I have titled

POSTED BY: Angelica Jusino
4 Replies

Bruce, No, I doubt the whiteboard falling had anything to do with my .nb file. I am still having the issue however. Same symptoms as before... nothing has changed.

POSTED BY: Angelica Jusino

Except for the dynamic content warning, this window is for when you closed the last Mathematica 10 window.

If you open notebooks by double-clicking on them, try opening Mathematica first and then use File menu - Open to select the notebook.

If you open the notebook from File menu - (recently opened notebooks list), try using File menu - Open to select the notebook.

If you get this window from using File menu - Open, try double-clicking on the notebook in a Windows Explorer or My Computer window.

Heavier tests:

  1. Hold down the SHIFT and Control keys as Mathematica starts. This resets initialization files, in case one was damaged. This also resets the list of recently opened notebooks and global Mathematica preferences. (See http://support.wolfram.com/kb/12464 .)
  2. When you open the notebook from File menu - Open, try opening it with the read-entire-notebook option:
    • File menu - Open,
    • select the notebook to open (click once),
    • click the OPTIONS button in the bottom of the dialog,
    • in the Notebook Options window, click the check box in front of Parse and load entire notebook on opening,
    • click OK to close the Notebook Options window, and
    • click Open.

See the attached screen shot.

Attachments:
POSTED BY: Bruce Miller

Bruce,
Thank you for your reply. I had tried opening the file from all of those avenues before posting, and they all resulted in the same window. As for your other suggestions, the SHIFT + CTRL worked in resetting my most recent opened files, but I still got that small end window. When I went into the options, I was able to select the option you told me to, but I (once again) resulted with the same window as the one in my screen shot.

The same day this happened, I came home to find my whiteboard above my computer had fallen off the wall, spilling a few document magnets onto my keyboard. I remote in to my home computer at school (In use a Microsoft Surface RT so I cannot support large programs on the tablet), so while I was trying to open this file, I had no idea I had magnets on my source computer. I save everything to OneDrive (app installed to my computer), so I don't know if this had something to do with it. I had saved the file on the 8th, tried to open it on the night of the 14th, posted this the 15th, and the magnets fell after my post.

POSTED BY: Angelica Jusino

Are you saying the problem is fixed? Or worse?

"the magnets fell after my post" sounds like the whiteboard was not relevant to the notebook problem.

POSTED BY: Bruce Miller
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract