Message Boards Message Boards

0
|
14429 Views
|
6 Replies
|
0 Total Likes
View groups...
Share
Share this post:

Misbehavior of GeoGraphic Functions

Posted 10 years ago

There is a bunch of functions which don't work in my Student Edition of Mathematica 10.

For instance:

GeoGraphics[Polygon[Entity["Country","Italy"]]]

AdministrativeDivisionData["SampleEntities"]

GeoRegionValuePlot[{Entity["Country","Germany"]->2.2,Entity["Country","UnitedKingdom"]->3,Entity["Country","Norway"]->4.5}]

GeoListPlot[EntityClass["Country", "EuropeanUnion"]]

Some of them pretend to function by showing me a map of Copenhagen.

enter image description here

I am particularly interested in AdministrativeDivisionData[] and GeoRegionValuePlot[]. How do I make them work?

POSTED BY: Sandu Ursu
6 Replies
Posted 9 years ago

My version is indeed 10.0.73.

And the problem seemed to be related to that. For instance, CountryData["EU"] resulted in 28 unevaluated Entity["Country",~].

I understood that it should have been a server issue after I have defaulted everything and cleaned all AppData files created by Mathematica and those which remained from the previous versions.

Currently everything is working fine.

POSTED BY: Sandu Ursu

This is probably the same entity problem in http://community.wolfram.com/groups/-/m/t/501941

POSTED BY: Sean Clarke

These examples occasionally fail for me if I run a large number of them. So maybe it's an issue with the server timing out.

What version of CountryData is installed on your machine?

"Version" /. PacletInformation["CountryData"]

This should probably say 10.0.73

POSTED BY: Sean Clarke
Posted 9 years ago

Hi, Sean

I have to ask for help again.

The problem reappeared and persisted since. Fortunately, I didn't have to use related functionality extensively and what I had to do I did in the Cloud.. waiting for the better 10.1 version.

Now I face the same problem and I wish to know if it is possible to remedy it. A clean start doesn't help.


A lot of the "Geo" functions don't work.

enter image description here

Nor does CountryData[] work for me.

POSTED BY: Sandu Ursu
Posted 10 years ago

Performed a clean start.

Works perfectly!

Thank you.

POSTED BY: Sandu Ursu

Do they give you any error messages? This functionality requires that you can connect to the proper servers.

Try running the connectivity test in this article? Does it work? http://support.wolfram.com/kb/12420

The behavior is strange. I haven't seen it before. If you haven't tried to clean out your Mathematica preferences, you may want to try that:

http://support.wolfram.com/kb/12464

POSTED BY: Sean Clarke
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract