Message Boards Message Boards

0
|
7315 Views
|
3 Replies
|
0 Total Likes
View groups...
Share
Share this post:
GROUPS:

Following Error in SystemModeler (MacOSX Yosemite)

Posted 10 years ago

Hi, I just downloaded system modeler and cannot simulate any of the examples provided. I am receiving the following code:

Building "BioChem.Examples.MealSimulation.MealSimulationModel" as experiment "MealSimulationModel 1" started at 12:39:03 
Error: [:0:0-0:0]Error building simulator. Build log: 
[:0:0-0:0]Forcing static selection of states. If this leads to problems during simulation turn on dynamic state selection.
Error: No executable generated /var/folders/h4/75mvnh257qzdkxr1dkch8p_80000gn/T/sme.4.0.1_1417459143_282475249.exe

Does anyone know how to fix this? Thanks in advance.

Sincerely, Alejandro

POSTED BY: Alejandro Braun
3 Replies
Posted 10 years ago

It sounds like there's a problem with you XCode setup. Can you compile a simple "Hello World" program? Create a file test.c:

//
//  test.c
//

#include <stdio.h>

int main(int argc, const char * argv[]) {
    //Print to console:
    printf("Hello, World!\n");
    return 0;
}

Open Terminal and navigate to where you saved the test.c file. Run the following commands:

$ gcc test.c
$ ./a.out

The following should now print in your Terminal window: Hello world.

POSTED BY: Johan Rhodin
Posted 10 years ago

Hi, I didn't see your reply. It says "No log file".

POSTED BY: Alejandro Braun
Posted 10 years ago

Alejandro,

What happens if you do the compiler verification? (Open Preferences by pressing Cmd + , or from the SystemModeler Menu select Preferences. Select Global->Compiler and press "Verify")

Try opening XCode. Make sure that the license agreements for XCode has been accepted (this has to be done manually when XCode updates).

POSTED BY: Johan Rhodin
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract