Message Boards Message Boards

3 Replies
2 Total Likes
View groups...
Share this post:

Double integration; sphere

Posted 9 years ago

Hi !

I have a problem with the double integration on a sphere. The .nb file created with the older Mathematica version produces the result of the integration while the .nb file creted with Mathematica 10.0 just produces the representation of the double integral, but actually does not integrate it. The integration limits are defined, see the attached image. Please Help ! .nb file with not calculated integral .nb file with the calculated integral

3 Replies
Posted 9 years ago


the problem was with the MattrixForm; I removed it and things start to Work ;-) It seems that // MatrixForm turns the data into some other format than multidimensional array, however in Mathematica help page the MatrixForm is defined as: MatrixForm acts as a "wrapper", which affects printing, but not evaluation.

Thank you for the assistance !

Posted 9 years ago


thank you for the fast feedback!

I tried Your both suggestions: -- inserted rational numbers--> did not work; -- lowered the order of the integration --> did not work

I tried to integrate separately odf[theta1, phi1] and this works good. Actually the problem is with the integration of the 4th order tensor; it does not substitute the values for the arguments. I am wondering I have the .nb file which is created with the older Mathematica version and it produces all the results having run on Mathematica 10.0.

The both files are attached to this e-mail.

File created with Mathematica 10.0: elastmat_rot.nb File created with the older Mathematica version: 1matrix-rotation-2a.nb


It's hard to debug a picture. Can you attach a clean notebook with just the code that needs to be debugged?

It's possible that Integrate doesn't know how to solve the integral. Does the order of integration matter in this case? If not, try switching the order of integration. You might also try replacing the floating point values in the integrand (like 0.3333333) with rational values (like 1/3).

It looks like your integral has a matrix in it? Make sure that the integrand is a vector. I see you are also using MattrixForm or some special formatting funcitons. Try removing these.

One thing I do is try to find the smallest integrand which reproduces the problem. That is, I strip away parts of the integrand until I get the smallest integrand that won't integrate. This helps me understand what in particular is difficult about the integral.

Have you tried numerically solving the integral with NSolve?

POSTED BY: Sean Clarke
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract