Message Boards Message Boards

1 Reply
2 Total Likes
View groups...
Share this post:

Mathematica won't start after upgraded to latest version

Posted 9 years ago

Hi, I'm using OSX Yosemite, and I'm having trouble getting Mathematica to start after upgrading to the latest version. The previous version of Mathematica ran fine. I just made the upgrade today. By upgrade, I mean that I deleted the Mathematica icon from my Applications folder, and then did a clean install. After I installed it, I tried to open Mathematica by right-clicking the icon and clicking "open". A small bar saying "Verifying Mathematica" opened and ran for about 2 minutes. Then a message saying something like "This application is not recognized and might be dangerous to open" appeared, and there were two buttons: Open and Cancel. I clicked open, and then absolutely nothing happens. I see the Mathematica icon in the bar on the bottom of my screen. There's no black dot under it, the way there usually is when an application is successfully running. However, I did not lock the Mathematica icon to my bar, so the icon shouldn't be there unless it's running. Activity Monitor shows that it is running, but it doesn't say anything about it not responding. If I right click the icon in the botton bar though; it says that Mathematica is not responding. Does anyone know what's going on? Thanks.

POSTED BY: David Liu
Posted 9 years ago

Ah, never mind. I installed the latest version of Java and now it works. I'm not very happy with the overall experience described above, though. The previous version of Mathematica worked fine on my computer before I installed the new version, so it's surprising that I would have to update Java. Even so, why was there no message telling me that I should update Java? That would have been very helpful, and would have saved a ton of confusion and Googling.

Also, on a related note, I am getting another issue that I've gotten before in a previous version of Mathematica. I believe there is also a thread in the forum where another user has the same problem. For the very first command, even if it's something simple like "1+1", if I try to evaluate it, then it hangs indefinitely. I have to go to Evaluation -> Abort Evaluation to get it to stop. Then everything works fine after that. This seems to be a mild annoyance, but I wonder why it hasn't been fixed. The other thread seemed to suggest that this has something to do with the suggestions bar though.

POSTED BY: David Liu
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract