Message Boards Message Boards

0
|
12746 Views
|
6 Replies
|
0 Total Likes
View groups...
Share
Share this post:

ModelPlug does not show the board capabilities. How to solve this problem?

Posted 9 years ago

Hello, I´m trying to create a Hardware-In-Loop-Simulation with an ArduinoMega2560 and the ModelPlug Libery. But I reach no communication between the SystemModeler and my ArduinoBoard. After I installed the ModelPlug Libery I followed the "Getting Started"-Tutorial and I tryed to test the BlinkingLED example, but for some reason it does not work. The "Simulation Log" did not showed a message like in the tutorial (shown below), part (C) to (F) was completely missing.

http://reference.wolfram.com/system-modeler/libraries/ModelPlug/resources/info_0009.png

Because of this, I think that ModelPlug is not communicating with my ArdunioMega2560 in the right way. Of course I was checking the troubleshooting-hints and I have uploaded the StandartFirmate a lot of times, but the outcome was exactly the same. The BlinkingLED was not working and the report in the Simulation Log does not change. I also got the latest version of the Arduino-Software ARDUINO 1.6.5 and the latest version of Firmata 2.3.6. But all of my working and doing did not solve my problem. Now I really have no idea how to solve this problem and start my own Hardware-In-Loop-Simulation. Thanks for your interests and I hope some of you have a solution for me. With the best regards.

POSTED BY: Moritz Schreiber
6 Replies

Try with changing the parameter 'UseDTR' in the Arduino model. Some boards like the Arduino Leonardo need this parameter set to 'true', other boards need to be set to 'false'.

In the Firmata web page ( http://firmata.org/wiki/Main_Page ) you can find the 'FirmataTest' program. You can use it to check if your board is working properly. If the board does not work with 'FirmataTest' it may not be a problem with the ModelPlug.

Hello again,

as I promised, I was testing the BlinkingLED example with an Arduino Uno again. This time it worked well. But I got no chance to do the same with the Arduino Mega 2560. I made a screenshot of the SimulationLog after I used the ArduinoMega 2560. Maybe it will help you. As you can see, there is part (C) to (F) from the "Getting Started" example is missing.

enter image description here

Now I will use the Arduino Uno in future to make further tests.

With the best regards.

POSTED BY: Moritz Schreiber

Hi Bro. Hope you are well. I am facing the EXACT same problem. But I do not have an Uno :P

Were you able to make it work on 2560?

Anxiously waiting for reply!!

Thanks

POSTED BY: Safi Ahmed

Thanks for your fast reply! I am using a trial-version of SystemModeler 4.1. for my work with ModelPlug. And I hope that it should not matter that I use a license for 30 days. The SystemModeler is running under the operation system Windows7. Of course I tried to solve my problem with rechecking the COM-port and the other ports. I also synchronized it with real-time. I verified all of your troubleshooting hints from the "GettingStarted" tutorial. Everything sould be fine. The next step I want to do is using an Arduino Uno instead of an Arduino Mega 2560, to make sure that the problem is with SystemModeler. I am quite sure, that my Arduino Mega 2560 is working correctly, because I worked with it in the last few days.

POSTED BY: Moritz Schreiber
Posted 9 years ago

Did you turn on Synchronize with real-time? Did you specify the correct port for the Arduino? Which operating system are you using?

POSTED BY: Johan Rhodin
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract