Message Boards Message Boards

GROUPS:

Mathematica Demonstration Initialization Problem with Ubuntu

Posted 3 years ago
5033 Views
|
3 Replies
|
0 Total Likes
|

Hi!

A Demonstration file with the code

Manipulate[a, {{a, 1}, 0, 2}]

gives upon loading the demonstration the following output (before evaluating manually with Shift+Enter)

1. + X Axis

I tested some demonstration from the wolfram site and they too load with wrong initial values for the controllers.

The problem occurs with Ubuntu, I could not reproduce it with Windows.

Please let me know if I can fix this problem.

Thank you, Tukan

3 Replies

I suspect we will need more information (what Demonstration, what specifically did you download, etc.)

Posted 3 years ago

The problem occurs when I create an own Demonstration (New -> Demonstration), add the code

Manipulate[a, {{a, 1}, 0, 2}]

in the Manipulate section, run, save and restart Mathematica.

For the examples from the Wolfram Demonstration Project only some work. Just tried the first one popping up on the webpage ("Quasicrystals" - in the CDF version) and it does not run but produces errors, probably because the Controllers are somehow incorrect initialized.

I tried with Mathematica 9 and 10. My OS is Ubuntu 14.04.

Posted 3 years ago

Still trying to solve this problem...

I think the problem related to the StyleSheet: when I change it from Demonstration to Notebook, the Manipulate initializes correctly when restarting Mathematica.

Please let me know if you have any ideas what to try.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract