Message Boards Message Boards

GROUPS:

Mathematica 10: Notebook Freezing (auto-completion?)

Posted 5 years ago
20077 Views
|
14 Replies
|
4 Total Likes
|

I've just installed Mathematica 10, on Windows 7, but am having problems with the notebook freezing. Specifically, the problem seems to occur when typing functions, at the point where the predictive interface will try to suggest an autocomplete for the function. The notebook will freeze for 30 secs or so, and the window will report "not responding". It resolves itself eventually, presenting the autocomplete menu, but the delay makes using MMA 10 practically impossible.

The kernel seems to be fine.

Is this a known bug?

14 Replies

Though I do not know if this is a known bug (and I am on a Mac), you can bypass the autocompletion by going to the Preferences pane (from the Mathematica menu) and on the "Interface" tab uncheck "Enable autocompletion with a popup delay of xxx seconds". You can still bring up the autocompletion popup by typing command-k on the mac or (I think) alt-k on Windows. You can also leave the checkbox checked but change the default number of seconds for the popup to appear from the default of 0 seconds to a larger number.

Thanks for the tip David. I had thought of delving into the preferences to see whether I could turn autocompletion off, but it's a feature I rather like! In any case, after multiple crashes, Mathematica 10's kernel decided it had licensing 'issues' and I think had become corrupted. I had to uninstall it. I hope a speedy bugfix for Windows users is forthcoming, but for now, I'm back to version 9.1.

Posted 5 years ago

I face the same problem with Windows 8.1. Back to using Mathematica 9 now.

I briefly experienced something similar on my Windows machine, however the problem went away after starting with clean preferences and deleting the contents of $UserBaseDirectory.

I keep getting the same issue as the OP. I've tried all of the above and it still freezes upon auto-completing even after I've increased the time and write simple functions as Plot, Solve, Factor etc. which takes less time to type than the auto-completing threshold I've entered.

Posted 5 years ago

I have the same problem as well with Mathematica 10 on windows 7 64-bit . Quite annoying and makes mathematica nearly impossible to use. Any update whether this is a known problem? I may have to downgrade to Mathematica 9.0.

I solved the freezing problem! Deinstall the Graphik driver for NVIDIA GEFORCE 9400GT. Mathematica 10 starts without delay.

The issue is caused by the file that is supposed to make the prediction of your autocomplete better. Go to $UserBaseDirectory/.Mathematica/SystemFiles/FrontEnd/SystemResources/FunctionalFrequency and check the .m-file there. Everytime this happens to me, this file was several hundred MB large. Deleting it solves the problem.

I also just hit this!

Thank you so much, @Matthias König, for the workaround!

On the other hand: Why, Wolfram?! Why?

The files in this directory store your autocompletion history to help the system make accurate completions based on your past choices. Several hundred megabytes seems quite excessive. If anyone here encounters this problem again and there is a very large file in this directory, you can help me track down the problem by sending the file into tech support along with a description of the problem (assuming that deleting the file actually does cure the issue). I'll get notified and be better able to fix the issue.

Tom

No problem, it happens quite frequently to me. A shame as well, since autocompletion without this file favors some weird suggestions sometimes (like when you type Integ... it will suggest "Integer" rather than "Integrate").

I have the same situation. The file was almost 1GB. I deleted and it solved the problem. If I get it again, I'll send it to you.

Is there a way to disable storing command history, and just have autocomplete in alphabetical order?

You could write a modified start-up script that deletes the CodeAssist-File every time before launching Mathematica.

Tom: I just reported a bug of this kind and sent the file (407mb) to tech support.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract