I guess that depends on the way it will be used, but what about a definition like the following (of course, the "new" function can be named as desired)
lpMaximize[c_, rest___] := LinearProgramming[-c, rest]
lpMaximize[{1, 1}, {{1, 2}}, {3}, {{-1, 2}, {-1, 1}}]
(* Out[3]= {2, 1} *)
We could also let LinearProgramming automatically do the above if the last argument is "Max", for example:
Unprotect[LinearProgramming];
LinearProgramming[c_, rest___ /; Last[{rest}] === "Max"] := LinearProgramming[-c, Sequence @@ Most[{rest}]]
Protect[LinearProgramming];
LinearProgramming[{1, 1}, {{1, 2}}, {3}, {{-1, 2}, {-1, 1}}]
(* Out[11]= {1, 1} *)
LinearProgramming[{1, 1}, {{1, 2}}, {3}, {{-1, 2}, {-1, 1}}, "Max"]
(* Out[12] = {2, 1} *)