Message Boards Message Boards

0
|
18325 Views
|
7 Replies
|
8 Total Likes
View groups...
Share
Share this post:

RLink[ ] does not work after R update

Hi,

I have updated R to R 3.0.2, and now my RLink does not work anymore. Can anyone help me?

Thanks,
Christian
7 Replies

The issue of RLink's incompatibility with R3.x is being worked on, and the fix is coming. You may expect it to appear in one of the following point releases. In the mean time, I will post any updates (such as if some temporary patches become available) here on this page, so stay tuned.

POSTED BY: Leonid Shifrin

Thanks, inspired by your reply I tried the following on my Windows 7 computer. What am i doing wrong?

Needs["RLink`"];
SetEnvironment["LD_LIBRARY_PATH" -> "C:\\Program Files\\R\\R-3.0.3"]
InstallR["RHomeLocation" -> "C:\\Program Files\\R\\R-3.0.3"]

InstallR::fail: Failed to install R. The following error was encountered: Unable to load dynamic libraries >> tried the following on

LD_LIBRARY_PATH is a Linux-specific thing. I believe RLink does not currently (as of Mathematica 10.0.0) work with R 3.0 or 3.1 on Windows. You'll need 2.15 or earlier while waiting for an RLink update.

POSTED BY: Szabolcs Horvát
Posted 10 years ago

I had a similar issue, Debian GNU/Linux. I resolved the problem by adding the R path:

Needs["RLink`"]
SetEnvironment["LD_LIBRARY_PATH" -> "/usr/lib/R/lib"]
InstallR["RHomeLocation" -> "/usr/lib/R"]

REvaluate["sample(1:100,10)"]
{1, 96, 85, 57, 48, 68, 58, 98, 94, 90}

I should point out that this invokes a version of R that I installed myself. It does not fix (directly) the issue with the version of R provided by the Wolfram download.

POSTED BY: Eric Brown

Does anyone know if the problem has been solved in version 10. I was not succesful on my first attempts.

Posted 11 years ago
Just a clarification: I'm assuming you're on Windows since the RLink paclet uses R 2.14.0 and the "RHomeLocation" option to use another installed version is only supported on Windows.

To the best of my knowledge, RLink doesn't currently work with any R 3 on Windows. Using 2.15.3 seems to work fine for me, though. Unless R 3 is necessary, you may want to give 2.15.3 a try.
POSTED BY: William Rummler
Posted 10 years ago
Is there any patch or workaround to get Windows RLink to work with versions greater than 2.15.3 or is this set until version 10 of MMA?
POSTED BY: Peter Crosbie
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract