Message Boards Message Boards

GROUPS:

StartExternalSession with a Raspberry Pi Stretch running MMA v11.2?

Posted 2 months ago
400 Views
|
5 Replies
|
1 Total Likes
|

Hey guys,

I wondered if anyone had an issue with Raspberry Pi Stretch running MMA v11.2 in which calling

StartExternalSession[<|"System"->"Python,"SessionProlog"->"import math"|>]

yields an error accusing invalid option "SessionProlog".

I've used this on MacOS and it works fine, but it is crashing on the Pi.

I can't seem to upgrade it to v 11.3 to check is that is the issue.

Anyone encountered this issue?

5 Replies

Option SessionProlog was introduced in 11.3. It will be an invalid option for 11.2 Kernels. Hence the error.

Thanks, Damanjit!

Any idea when v 11.3 will be available to the Raspberry pi?

Version 11.3 for the Raspberry Pi was released a week ago. You should be able to upgrade via the usual

sudo apt-get update

sudo apt-get install wolfram-engine

and this is a direct link to the .deb package

Thanks, Ilian!

I tried updating a few days ago but I got a message saying version 11.2 was the latest. Tried again last weekend and managed to update it.

Much appreciated!

Any way we can flag this topic as closed?

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract