Message Boards Message Boards

GROUPS:

Internal`$VideoEncodings gives a strange message

Posted 18 days ago
200 Views
|
2 Replies
|
1 Total Likes
|

When I was calling

Internal`$VideoEncodings

Mathematica gave a message:

ImportExport`RegisterFormat::noexe: Could not install QuickTime.exe.

and the output is not a list but

System`ConvertersDump`out$2191

I just don't understand why this happens. I have this problem with Windows 10 and Mathematica 11.3.0, and I have tried installing Quicktime 7.7.9 from Apple and it did not solve this problem.

Is there anybody having the same problem?

Thanks.


Edit 1:

I checked the same code with Mathematica_10.4.1 and it worked well!

Then I checked the installation directories of these 2 versions of Mathematica and searched for the file "QuickTime.exe". It turns out that this file exists in 10.4.1 but no in 11.3.0. I think this may causing this problem.

2 Replies

QuickTime.exe was removed in version 11.3.0 for Windows, but Internal`$VideoEncodings should still work correctly and should return {"H264"}. This bug will be fixed in version 12.0.

Thank you. I am looking forward to the new version.

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract