Message Boards Message Boards

4
|
6678 Views
|
2 Replies
|
4 Total Likes
View groups...
Share
Share this post:
GROUPS:

Some notes on installation and startup

Posted 11 years ago
These are some notes about things I encountered during startup of my RPi and installation of Mma - notes that could have saved me some time, reduced my FUD and raised my confidence if I had found them somewhere before I started. 

Hardware:
recent RPi from Element 14, power supply from LadyAda.
Samsung LED TV through HDMI
Apple-based home network
Ethernet cable to Internet via DSL modem
16GB microSD card, USB adapters and SD adapters as necessary.

Procedure:

I tried installation first with a 4GB card (there are a lot of places that recommend this as a minimum, but they must not be figuring Mma too. The card ran out of space.

On a Macbook Pro, I downloaded the latest SDFormatter program and did a full format of the microSD card.
Still on the MBP, I downloaded the default OS package (NOOBS_v1_3_2-2) from raspberrypi.org.
This download is apparently different from most earlier versions in that it doesn't require the the intricate steps (described in almost every other RPi startup page) to unzip and translate before loading onto the SD card. You can simply unzip this one in place (e.g. in the MPB Downloads folder) and copy/paste the files in Finder (after you read the readme to make sure you get the root directory in the right place.)

After booting the RPi, I clicked the recommended Debian release. Command line and GUI versions came up functional. Many startup instruction sets you find on the web advise you to set up, in the config screen, the SD card to use its full capacity, but in this NOOB setup, that's all taken care of. I had to set the localization stuff - time zone and en-US character set. You can get back to the config file later from the command line or from the LXTerminal program with sudo raspi-config. If it's been few a decades since you last worked through a text-based menu system, remember to use 'tab' to navigate, 'space' to select.

sudo apt-get update && sudo apt-get install wolfram-engine ran undramatically. On my installation, ~$ mathematica from the RPi command line fails, because the display can't be found. Although ~$ wolfram gives a functional command line of Mathematica, its utility is limited because the system graphics programs such as gpicview or gimp don't function properly from Run[]. Neither works on my system in any case.

Running LXTerminal from the RPi command line and running either $ wolfram or $ mathematica from that seems to produce a fully functional system.

There was a recent thread here about viewing and manipulating graphics with gpicview. This evidently is a part of the standard Debian installation, because the examples just work. The Linux program gimp is a heavyweight graphics program that gives heavyweight graphics capability. I installed it with instructions from Simon Monk O'Reilly Raspberry Pi Cookbook. $ sudo get-apt install gimp.

Because I have ambitions to demo and use this system at the local geek club, I wanted to be able to print from Mma, and, at least at the current version, there's no support in the File menu. How-To Geek  lists steps for installing the cups program. There are a lot of steps to get it working, but I had no surprises. You end up with a printer config interface at http://localhost:631/

I wanted to set my network printer as the default so I could use the terse Mma arguments. With a little digging, I got this to work:

$ lpstat -p -d gives you a list of current default and available printers, and pick out the one you want. For me this was 

$ lpoptions -d EPSON_EPSON_Epson_Stylus_NX430

It just works. Now things like the following can be used in Mathematica:

tempPlot = Plot[...
Export["temp.png",tempPlot]
Run["gpicview temp.png &"] (* displays tempPlot on the screen, gpicview menu File>Print works *)
Run["gimp temp.png&"] (* displays tempPlot on the screen with tools, gimp menu File>Print works. gimp seems only capable of printing one page of a multipage file at a time *)
Run["lpr temp.png &"]  (* prints directly *)

A similar procedure can be used to File>Save As... a Mma notebook as a .pdf e. g. and send that to the printer, either from the command line or from within Mma with a Run[.... Right now, this produces a result that is not ready for prime time. The fonts in the resulting printed document are badly rendered (letter-to-letter spacing is far too small), and it probably isn't good enough even to submit homework with.

We're so spoiled that we complain about such a thing when we should be struck dumb with amazemant that we can get it to work at all. Sorry. 

I'll post more when and if I can figure out more about the system.

Fred Klingener
POSTED BY: Fred Klingener
2 Replies
I think Apple now distributes X Quartz, their X11 implementation, here: 

http://xquartz.macosforge.org/landing/

If you then run ssh -X to your Raspberry Pi (e.g. ssh -X pi@raspberrypi), you should have x-forwarding back to your Mac. The session should have a DISPLAY variable set, so running mathematica will bring up a Linux-ARM Mathematica notebook session on your Mac. If you run wolfram in such a session, it should have the ability to Rasterize[] and such since it will detect your X server on your Mac (you may see a brief screen flash when this happens). 

However, if you have a desktop with Mathematica available, using our RDK or Remote Kernel functionality is an even better way to connect to a Raspberry Pi remotely. 

edit: formatting, clarity
POSTED BY: Alex Newman
I'm surprised that you don't get a $DISPLAY error when trying to run LXTerminal as well, but I don't know much about Mac OS and how it handles X-windows commands.  For those using a PC, a combination of Xming and Putty can allow you to ssh into your RPi with x-forwarding and get the Mathematica GUI to run properly.
POSTED BY: BoB LeSuer
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract