Message Boards Message Boards


Solve a problem with remote kernels configuration?

Posted 2 years ago
2 Replies
2 Total Likes

Hello everybody !

I want Mathematica 12 on my Macbook Pro ("client" in what follows) to connect to Mathematica on a quad core iMac (Personal Use License, named "host" in what follows) to distribute quite a heavy computation across parallel kernels.

1. I first thoroughly went through the tutorials on both Lightweight Grid manager as well as remote kernels configuration, but I can't make either work. Lightweight Grid manager works fine on my host: what is recommended to check at

was checked, but when my cleitn tries to connnect to the host, RemoteServicesAgents[] does return the IPv6 address of my host but LightWeightGrid would not connect to it. I tried to run HostLookup[IPAddress[...]] where the dots stand for the IPv6 address of the host and the function would not find the host; thinking that there could be an issue with IPv6 instead of IPv4 addresses, I disables IPv6 addressing on both computers and restarted both systems, but the gridMathematica server would still produce the same IPv6 address and the problem would persist.

2. Next, I tried the remote kernel activation, by using the shell command
ssh -x -f -l 'myusername' 'host.local /Applications/ -wstp -linkmode connect tcpip -linkname linkernel -subkernel -noinit > & /dev/null &

which fails, returning the error

SubKernels::Subkernels:: Timeout for subkernels, received 0 out of 4 connections." I extended the time constraint, to no avail. Moreoverm when I execute the command above in the cleitn terminal shell, I get the message

LinkConnect::linkc: -- Message text not found -- (LinkObject[linkernel, 3, 1])

Of course the two computers are configured to communicate through a private/public ssh key pair and I have tested this separately in advance on the terminal and it works juts fine.

(Maybe) a hint: when I try to use URLRead["host.lan"], URLRead would fail to connect, even if I supplement it with Usernae and Password.

Any help would be greatly appreciated.



2 Replies
Posted 1 year ago

Hi Juan, yes I did, somehow: eventually I installed the update of Mathematica restarted my computer and WolframLightweight Grid started to work. I did not try anymore to invoke the remote kernels with the functionality available through the Remote Kernel window.

Best, Mirko

I'm having a similar error in a different scenario for launching remote kernels. Did you figure it out?

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract