Message Boards Message Boards

0
|
10509 Views
|
3 Replies
|
0 Total Likes
View groups...
Share
Share this post:

JavaGraphics not functional with Wolfram language on RPi

Posted 11 years ago
I would like to use JavaGraphics with the Wolfram language on RPi. This is the advertised way to use graphics with the kernel (<< JavaGraphics`). I t needs an x-server which I have working. From the root terminal, it loads the package (package is initialized but says first::first {} has length of zero} but crashes when I try to use it (java.lang.Null.PointerException). It is very clunky to have to export graphics to see them. Is this a bug or something not quite ready? Thanks
POSTED BY: david p
3 Replies
Posted 11 years ago
Bruce and Todd-

Thanks that did the trick! I never got a prompt and effective response like this before. I still get the  first::first message and it takes some time to get started, After that it blits each plot in its own window (Out). I put the file in:

/Opt/Wolfram/WolframEngine/10.0/SystemFiles/Links/JLink

For setting up xwindows I use xdm as described here.

http://www.straightrunning.com/XmingNotes/pixming.php
POSTED BY: david p
Wow, the NullPointerException turned out to be a one-line bug that dates back many years to the very beginning of J/Link, but had never been exercised until now. I have made a fixed JLink.jar file available for download at  https://download.wolfram.com/?key=WANXSL  (it will only stay up for a week). Replace the existing JLink.jar at <Mathematica dir>/SystemFiles/Links/JLink.
POSTED BY: Todd Gayley
Duplicated.  I will ping developers about it.
POSTED BY: Bruce Miller
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract