Message Boards Message Boards


Manipulate not working on Wolfram Cloud

Posted 6 months ago
6 Replies
3 Total Likes

Hello everyone,

I am trying to create an interactive plot that asks user to enter the 5th, 50th, and 95th percentile of a random variable and then plots the corresponding PERT distribution. I wrote such a code using a Manipulate command, and the code works fine on my desktop version of Mathematica (Version 12.0)

I would like to publish the code on the Wolfram Cloud so anyone can use it without having to download anything. When I publish the code to Wolfram Cloud, however, some of the functionality no longer works (see link). Specifically, when values are entered into all of the input fields, the plot initially produces the correct answer. It then, however, freezes after roughly three seconds and resets to the default screen (with no user inputs entered). Does anyone know what is going on? I tried adding a Module[] command to prevent automatic reevaluation and also added Synchronous Updating -> False to prevent the program from timing out during slow computations. Neither of these things helped.

Thanks in advance!

6 Replies
Posted 6 months ago

Hi Christoph,

I can reproduce the problem using the link you provided, however, if I make a copy of the notebook into my account without making any changes to the code, I am unable to reproduce the problem. My copy is here. Does it work for you?

Posted 6 months ago

Hi Rohit,

Thank you for the reply! I just tried opening your link, but it says I do not have permission to access it. Any chance you could change the permission settings?



Posted 6 months ago

Oops, sorry about that. Try now.

Posted 6 months ago

Yes, the link works! So how do your recommend I go about making changes if it doesn not work form my computer? Do you have any suggestions on what I can do to fix the problem?

Posted 6 months ago

Well, that is odd. I do not know how Wolfram cloud associates kernels with users or notebooks. Try "Restart Session" or "Quit Kernel" from the "Evaluation" menu. Maybe the kernel associated with your user/notebook is malfunctioning.

Posted 6 months ago

I tried restrating the kernel and it still doesn't work.

When I upload the notebook to WolframCloud it works fine on my cloud account. The problem seems to come when I hit "publish". The published version (that anyone, even without a wolfram account can acces) seems to not work. Is it possible that the link you shared with me was a shared notebook on Wolfram Cloud rather than a published version of the notebook?

Are there any crieteria that need to be satisfied for a published notebook to work?

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract