Message Boards Message Boards

GROUPS:

[WSG21] Daily study group: multiparadigm data science

Posted 3 months ago
4344 Views
|
108 Replies
|
26 Total Likes
|

A new study group for Multiparadigm Data Science with the Wolfram Language begins Monday, Apr 19, 2021!

Making progress in an online course can be daunting when you have to study all alone. Join a cohort of fellow Wolfram Language users for a two-week study group that works through the Wolfram U course "Multiparadigm Data Science". A certified instructor will guide each session by reviewing the lesson notebooks from the course, working through the code and answering questions.

Get support for starting on the path to earning Level 1 and Level 2 certifications in multiparadigm data science.

Sign up here: https://wolfr.am/UNdaIas0

108 Replies
Posted 3 months ago

Clicking the Download Notebook link did not result in a download for the sessions {Explore, Analyze, Handling different types of data, restructuring Data}.

Is there something else required to get the downloads?

Thank-you.

Posted 3 months ago

It seems like a hit and miss affair, sometimes it downloads , sometimes it does not, even when I tried a number of browsers . I think that is why we are getting a separate link in today's lecture so we can download all the files in one go .

Yes, we will share a link to download all the notebooks at once, in the study group session today. We'll also look into the issue of the "Download Notebook" links not working as expected. Thanks.

Posted 3 months ago

Thanks for the downloads.

I see the the 1st workflow notebooks were left out ("1. Build a Project Workflow"). It seems that the last three notebooks of that section have a non-working download link at the bottom of each notebook because I've tried three different browsers with the same result. I cannot download them, though I can probably reconstruct them via copy, paste, and execute.

No problem. We can add the "Build a Project Workflow" notebooks to the same download location.

Posted 3 months ago

Abrita, I can not find the "Exercises" in The MPDS notebook. I really appreciate it if you would help.

You will find the "Exercises" tab on the top right corner of the page for each lesson. E.g. https://www.wolfram.com/wolfram-u/multiparadigm-data-science/handling-different-types-of-data.html enter image description here

Once you go to a new subsection of the course, the Exercise-File is copied into your private Wolfram Cloud. It is much easier to work with the copy. You can work with the files either on the cloud or locally.

Posted 3 months ago

I don't understand. I don't see any automatic copying of the Exercises notebooks to my cloud account. I have to manually click the "download" link. It is available for some of the Exercises, but not all.

[Update:] I stand corrected. I found them. Thanks for the tip!

This is in reply to a question posed at today's study group session about listing wars from a particular period. I have used the "MilitaryConflict" entity type to create a FilteredEntityClass that satisfies a specific condition for its EntityProperties "StartDate" and "EndDate" with the help of an EntityFunction.

EntityFunction[x, body] behaves exactly like an EntityProperty and can be used to create very specific properties that help us denote a list of very specific entities

EntityList[
 FilteredEntityClass["MilitaryConflict", 
  EntityFunction[c, 
   c["StartDate"] >= DateObject[{1975, 1, 1, 0, 0, 0}] && 
    c["EndDate"] <= DateObject[{2000, 12, 31, 0, 0, 0}]]]]
Posted 3 months ago

Exercise 2.3.1 / 2.3.3 / 2.3.4 I get exactly the same solution as the expected solution. The solution check answers always with "Try again". What i am doing wrong?

Hi,
Please check my registration, because I do not receive your emails, and the Q&A display shows my surname first, followed by my first name. Perhaps I made a mistake during the registration process?

Posted 3 months ago

Hi Abrita

Firstly the notebook files would not download for me ( I am using windows 10 and a range of browsers ( Chrome , Mozilla and Edge ) . I suspect it is becasue the website wants to open a window and the Browser / Virus software will not allow it .

Now attempting the exercises and its is just not happening. The small window on the right will not show all the info, and if you enter info, it will not display correctly. ( I do get the right answer eventually) .

enter image description here

I agree, to edit the excercises is a nightmare. I lost the button to check the solutions for all sections.

Posted 3 months ago

Jürgen are you using Windows or Mac ?

Windows 10

Once you go to a new subsection of the course, the Exercise-File is copied into your private Wolfram Cloud. It is much easier to work with the copy. You can work with the files either on the cloud or locally.

Posted 3 months ago

Thanks , running the exercises in the cloud now

Quiz 1 - Problem 9

You are asking for a specific number regarding the "dimensions of the output returned by DimensionReduce". I think this is in contradiction to the Documentation Center where you can read
"DimensionReduce[examples] automatically chooses an appropriate dimension for the approximating manifold." So, the requested number for the quiz problem can be right, but must not be correct in general, right?

Posted 3 months ago

Jürgen

In general , if you use DimensionReduce without specifying a dimension it will reduce to a certain dimension (columns) . Try it out using Random Matrix's of random sizes and it will reduce to a certain dimensionality (columns) every time.

You are right, but let us assume you put images or other data into the DimensionReduce function, the dimensions change.

Correct. We are in the process of updating the answer options.

Hello, Let me try to address a number of questions here.

  1. Quizzes: We are addressing some issues we found with the quiz. @JuergenKanz The issue with Quiz 1 Problem 9 will be resolved in the fix we are deploying.
  2. Autograder not accepting solutions to exercise problems: We will discuss this in more details during Friday's session. @UlfSchmidt and @DougBeveridge We are also in the process of setting up a way for you to download the exercise notebooks, work on them on your desktop and submit for manual grading (especially when the autograder does not accept your solution). There are so many different ways to implement a solution in the Wolfram Language... although we have set up the autograder to accept multiple solutions, we do run into issues sometimes.
  3. "Download notebook" links: We are looking into the issue of the "Download notebook" not working. @DougBeveridge For now please download the zipped notebooks from the link shared during the webinar sessions.

Thank you for your patience as we try to resolve the issues. We appreciate your interest and participation in the study group sessions.

Posted 3 months ago

In Exercise 3.1.3 Visual Exploration

I am struggling to get the

enter image description here to work in enter image description here

getting the folowing error enter image description here any ideas

Posted 3 months ago

Hi Doug, there is something wrong with the formatting of the task. After simply selecting DarkBands as ChartStyle (as suggested by the task), I got a correct solution. See here http://reference.wolfram.com/language/guide/ColorSchemes.html

The incorrect formatting looks like "internal Mathematica code" - at least that's what you can see when you open a notebook with a text editor. Maybe a bracket or a quotation mark is missing?

larawag

Sorry about that. The question should simply read:

Represent the information from the previous problem:

    EntityValue[EntityClass["Country", "SouthAmerica"], "GDP", "EntityAssociation"] 

in a PieChart with automatic ChartLegends. Set the ChartStyle as "DarkBands".

Posted 3 months ago

Thanks Abrita

that works perfectly and the AutoGrader accepts it .

The notebook from today's review session has been uploaded to the study group materials folder.

Since a number of study group participants are working on the exercises, we are requesting that you do not post the solutions here on community. You are of course welcome to discuss various functions and provide examples of code that do not give away the entire solution.

If you are running into issues, where the autograder is not accepting your solution (although the output is identical to what is shown as the "Expected Output"), please feel free to email us at wolfram-u@wolfram.com.

Hi, there, I am working on Ex2.3.1, I run the first command, and get: enter image description here

Now I don't understand the question, "To be useful as a discriminative feature, each column should span a wide range of values across the samples. Find the number of unique feature values in each column of the dataset."

Posted 3 months ago

You should simply determine how many different numbers occur in each column.

Posted 3 months ago

Thanks for your clear explanation, Now I use MapThread[] to get the column list of data, from that point on, Ex1-5 are done now.

why does this code generate an error?

Attachments:
Posted 3 months ago

Q2 Problem 5

I think there could an "error" to the answer in this question

Posted 3 months ago

Exercise 3.3.5

We are asked to calculate some statistical figures "for the first column of the following dataset". The expected solution provides the results for the first row of the dataset. What do you really want?

Posted 3 months ago

Exercise 2.2.3

GroupBy[WordList[], StringTake[ToLowerCase[#], 1]&, Length]

Provided the answer but failed the grader. Did you have another answer in mind?

Don't worry. I have two slightly different solutions, but the grader does not accept them as well.

Quiz 3 - Problem 8

You ask for a shorter list, but the requested answer leads to an empty list. Is this what you really want?

Abrita,

Meantime I have participated in a number of Wolfram-U courses. I think it is fair to say that in each course we were facing issues with the auto-grader that is looking for certain code elements. Wouldn't it be better to compare the results with the expected output instead of the code? As you perhaps might know, I apply an unorthodox programming style which often leads to a number of auto-grader issues, but the results are okay. In the case of plots or images, this idea may not work, but a lot of discussed issues would not occur in the future.

Hi @Jürgen Kanz, We do appreciated your participation and feedback, as we try to resolve the various issues with the autograding of exercises. The grader has been set up to accept the variety of computations possible with the Wolfram Language and attempts to check the solutions in multiple different ways, based on the type of problem. We do use the approach you have suggested, in certain cases. We feel good about what the grader is doing right now but also realize we need to resolve a few more issues. All the feedback we are receiving from our study-group participants is definitely helping us out. Thank you.

I catch a bug in the Ex3.3.5 today:enter image description here

The first column should change to the first row here, check with following:enter image description here

0.338xxx is min of the first row,

Addressing some of the issues posted above:

Quiz

  • Quiz 2 Problem 5 - You will find the answer on the documentation page for WordCloud http://reference.wolfram.com/language/ref/WordCloud.html
  • Quiz 3 Problem 8 - The question should be rephrased "What value for AcceptanceThreshold t will return a shorter list of items for the following expression?"

Exercise

  • 2.2.3 The hint is steering the solution towards use of GroupBy, but you will need to use ToLowerCase and StringTake before you can use GroupBy. And Length after you have made the groups. Note: Of course this can be done much more simply by using LetterCounts. Even if the autograder does not accept the latter solution, we will accept it if you send it in as part of your final solutions.

  • 2.3.1 For example, the unique values in this list {1,5,1,1,5,5,5,1,3,1} can be found with DeleteDuplicates. Length can be used to count the number of those unique values. And you can do this for each column a data set. Transpose can be used to change columns to rows so you can easily Map your function on them. Note: Union would do the same work as DeleteDuplicates and again if the autograder does not accept your alternate solution, please email it.

  • 3.3.5 Expected output should be {23.6344,35.9256,66.2097,82.9443,90.5781}
Posted 3 months ago

Quiz 2 Problem 5 - You will find the answer on the documentation page for WordCloud http://reference.wolfram.com/language/ref/WordCloud.html

I did and that is why the query ...!

enter image description here

Hi Doug—I don't think that there's anything contradictory here, though it is a bit counterintuitive. The documentation can be easy to misread here, for whatever reason, so I'd highly recommend giving it another look!

Posted 3 months ago

Hi Arben Can you give me an example were enter image description here

will actually run , my view is the function is syntactically incorrect .

Because of the context of this being a quiz, I cannot give you a specific example. I can confirm, however, that that is indeed a valid syntax and that there is no error with the question as posed.

Posted 3 months ago

Solved , the variables W and S are swopped around (confusing ) in these examples , thanks

enter image description here

Posted 3 months ago

I'm playing around with different functions right now. I noticed that the order of the function arguments is not always the same, e.g.

enter image description here

and

enter image description here

These two examples show that once the list is first in (GroupBy[list, f]) and then as the second part (Map[f, list], MapThread[f, list], ...).

What is the hidden meaning of the swap of the order? Do the two functions belong to different classes that I don't know?

Hi Lara!

There's no real hidden meaning here; different functions with different intents will take inputs in different orders, even if they're of the same input type (here, List and Function or Function and List). The language design is such that we'd like to have the order be intuitive—in your case, we'd like to map f onto a list, so it's Map[f,list] or f/@list, but we'd like to Group a list By some function f, so there it's GroupBy[list,f].

We don't have different classes for our functions, and as you've seen many functions can take one argument, two arguments, or tons of different optional inputs—for each individual function, we've tried to make the order of the inputs make sense for that specific function.

Posted 3 months ago

enter image description here

I still don't get why we have to reverse the order in the third function . Is there a logical reason for that

This, I don't have a particularly good justification for. I suspect it might be mirroring RandomChoice, RandomSample, and other such functions, where weights are specified first when given in that format (List of Rules), but I'm not sure...

Posted 3 months ago

Thank you Arben, for your quick reply (and sorry for getting back to you only now...).

Now I am working on Ex4.3.2, and I try to write the distance function for FindClusters:enter image description here

Abs[StringLength[#1] - StringLength[#2]] & , this is according to the definition of f as following:enter image description here

I don't see anything wrong now,

Posted 3 months ago

It is a precedence issue, need parenthesis

DistanceFunction -> (Abs[StringLength@#1 - StringLength@#2] &)

You are right, after adding the (), now is working, thanks,

Good call, Rohit—when using Rule (->) with pure functions, it's good practice to group your pure function within parentheses. Otherwise, the pure function will often be interpreted as being (so to speak) (DistanceFunction->Abs[StringLength[#1]-StringLength[#2])&, which isn't quite the right grouping.

Daily Study Group Session Cancelled (Apr 27, 2021)

Our sincere apologies. It seems like BigMarker, our webinar platform provider, is facing some issues today. We are therefore unable to host the study group session.

We were planning to talk about Neural Networks in today's session. Instead we are asking you to look at the video at https://www.wolfram.com/wolfram-u/multiparadigm-data-science/neural-networks.html today. We'll discuss the code from the notebook at tomorrow's session.

Copies of the exercise notebooks (that show up under the "Exercises" tab on the right pane of the MPDS course) are also available for download in the course materials folder shared with you (link available in your reminder email).

I am working at Ex5.1.1 now, and the westernEurope, the second dataset in Association form doesn't show up, is all empty, don't know why and how to fix this now,enter image description here

You are right. There is an issue where ListPlot is unable to handle the multiple datasets in the EntityAssociation format. However the following should work:

ListPlot[{Values@easternEurope, Values@westernEurope}]

Now what remains, is to set up the labels for each data point. For example, for the first dataset the labels are available as Keys@easternEurope.

You will see on the documentation for ListPlot that one way to provide labels for data points is

ListPlot[{data1, data2, ...}]

where datai can have the form:

{y1,y2, ...}->{"lbl1","lbl2",...}

as well as

 {{x1,y1},{x2,y2}, ...}->{"lbl1","lbl2",...}
Posted 3 months ago

Hi Abrita, Arben,

Exercise 5.1.1 requires recasting the Dataset Association formats ...

Could either of you explain to me why this pattern matching statement doesn't operate on each element as it maps through all the elements of the association ?

easternEurope /.  KeyValuePattern[a_ -> b_] -> {QuantityMagnitude[b] -> a}

yields ...

{{6.30805*10^10, 9452409} -> Entity["Country", "Belarus"]}

Thanks, John Burgers.

Hi John,

That is a little confusing to me... in the meantime, [EDIT: this doesn't work, nevermind. Investigating...] I'll note that switching out KeyValuePattern[a_->b_] for Rule[a_,b_] works. I'm trying to think of why KeyValuePattern wouldn't, however. I'll update if I figure something out!

Hi again John,

It seems like this is a known issue—coincidentally, somebody has commented on it internally on this very day! In the meantime, here is an alternative construction that I think should generate the output that you want:

Association@KeyValueMap[QuantityMagnitude[#2] -> #1 &, easternEurope]
Posted 3 months ago

Thank you Arben, for the research, and suggesting a solution. John

Hi John—an update re: KeyValuePattern, which was the actual cause of the strange-seeming output that you saw. Basically, it works on a sequence of rules inside a List or Association, so once it found one match in your Association (in this case, for the first country, Belarus), it does the replacement on that and calls it a day. More technically, it's basically doing this:

ReplaceAll[easternEurope, 
Association[___, a_ -> b_, ___] :> {QuantityMagnitude[b] -> a}]

In any case, KeyValueMap is the more natural function to use here, as you are trying to Map some function which takes Keys and Values as its explicit inputs.

Posted 3 months ago

Hi John,

Another way to do it

easternEurope // QuantityMagnitude // AssociationThread[Values@#, Keys@#] &
Posted 3 months ago

Thank-you Rohit, that's an easily readable way of doing it. John

Hi Abrita, Arben,

I think something is wrong with your expected output for Exercise 4.5.5. When I take the output and decode it, the input sequence is as follows "GGTCTCCCAG". The original input sequence "GGCTCTTTAG" creates a different unit vector list compared to your expected output.

Am I right?

Thanks for the report @Jürgen Kanz . The expected output from a "Characters" encoder for the alphabet "ACTG" working on the input string "GGCTCTTTAG" should be:

{{0, 0, 0, 1},
 {0, 0, 0, 1},
 {0, 1, 0, 0}, 
 {0, 0, 1, 0},
 {0, 1, 0,  0},
 {0, 0, 1, 0}, 
 {0, 0, 1, 0}, 
 {0, 0, 1, 0}, 
 {1, 0, 0, 0}, 
 {0, 0,  0, 1}}

Exercise 4.4.4

You are asking for 26 new words! The expected output only shows 26 Characters. What has to be delivered?

Hi, Jurgen, That is the result I got, roughly 26 new words, space also counts as one word: enter image description here

We will rephrase the question text. Your solution should provide "26 characters" (individually most likely next 26 elements).

Posted 3 months ago

I would just like to thank the Wolfram U team for a fascinating and well presented course. Abrita, Arben and Sampurna were excellent instructors, very clear and very helpful in answering questions. I learned a huge amount and it has inspired me to go on to play with all sorts of ideas and possibilities that were raised in the course. Thank you again.

Similar opinions as above, I learn a lot from this course, now I have complete all the quiz and Exercises, it is something I can build on in the future. thanks for this tons of material course.

Posted 2 months ago

I'll just add "Hear! hear!" to that sentiment. I really enjoyed the course -- my only regret is that the course occurred at a time of year when I really would rather be outdoors, but that's on me.

Ron Goetz

How long will we be able to re-watch the web presentations?

Hi George! These recordings will be available in perpetuity :)

That is really great! I expected them to self destruct, like that did in Mission Impossible. That's what happened after the Neural Network Bootcamp, which was unfortunate. There was much more information, which also seemed more complicated.

@George Wolfe Please email wolfram-u@wolfram.com if you need any materials from NN Bootcamp. We will be happy to resend them to you.

Posted 3 months ago

I just completed Quiz 3 and click "GET RESULT". But nothing happens. I tried clicking a few more times, it still does not yield anything.

Hi Ohoe, Could you make sure you are still logged in to the cloud (at the top right corner of the page) and your session in the cloud somehow did not get disconnected?

Posted 3 months ago
  1. I am not able to get to "the page". How to get the page where the left side has lecture topics and " Quiz", "track the Progress"?
  2. I was able to access that page until this morning but now it is not available. Did you make some changes staring this afternoon?
  3. Hence, I am not able to follow your suggestion to check. 4.On the other hand, I clicked the Mathematica file and I find "open Cloud". There I am able to finish Quiz 3 to get result.
  4. I have difficulty with "Exercise": It goes through the cycle of "Check Solution" and "Try Again" even with a simple coding and the correct output. It happens with almost all Exercises. There must be something, which I can't figure it out.

Hi @Ohoe Kim,

I can confirm no updates have been made to the course site today. Are you referring to the "Track My Progress" page? It can be accessed here: https://www.wolfram.com/wolfram-u/multiparadigm-data-science/track-my-progress.html

I can confirm we have received your submission for Quiz 3.

Also for the exercises, if the autograder does not seem to accept your solution, but the output matches the "Expected Output", feel free to email it to wolfram-u@wolfram.com.

Hi Everyone,

Thanks for making the MPDS study group a success with your active participation. We appreciate all the great questions during the sessions, the posts on this community thread, and the reports emailed to wolfram-u@wolfram.com about the issues related to the exercises. Just wanted to share some links as we wrap up the study group series:

Certificate of Completion

Requirements: Attendance at study group sessions (or watching recordings) and completing the quizzes by May 7

Level I in Multiparadigm Data Science

Requirements: Attendance at study group sessions (or watching recordings), completing the quizzes and exercises by May 14.

We understand some you are running into issues with the autograder not accepting your solution that produces the same output as shown in "Expected Output". In those cases, we are requesting you mail us at wolfram-u@wolfram.com (a description of the issue and your exercises notebook - available for download both from the course page and the download link shared during study group).

Level II in Multiparadigm Data Science

Detailed instructions here: https://www.wolfram.com/wolfram-u/certification/level2/multiparadigm-data-science/

Finally, if you are interested, more details about the Wolfram Data Science Boot Camp 2021 can be found here: https://www.wolfram.com/wolfram-u/special-event/data-science-boot-camp/

Best, Abrita

Posted 3 months ago

Hi Abrita,

One month before the Study group, I passed the Level 1 certification using the online course “Multiparadigm Data Science”. In order to do the mentioned Level II later this year using the coupon, will I have to repeat the Level I of the Study Group, or is the existing certificate sufficient?

BR, Andreas

Hi Andreas, Your Level 1 certificate from the course already satisfies the requirement. Please feel free to use the discount.

Hi, Abrita, today I have received an email from Jan Fisher on the course completion certificate, howevere, my aim is on Level I certificate, I sent my submission email before May 7th, with 12mb exercises notebooks in a zip file, posted to my own authenticated website for username/password access, any single word on those submission?

Thanks,

Hi Vincent,

Thank you for checking in with us. We are currently in the process of manually grading the exercises submissions we have received so far (both via the online submissions on the course and via email). Thank you for your patience, as we finish up the grading. We will reach out to folks over email if we need to clarify any issues with their submissions.

best, Abrita

Hi, Abrita, I have just replied to Christine Owens's email to upload my exercises zip file to her provided uploaded link, now things has been clarified,

have a great day,

Posted 3 months ago

Hello, Would it be possible to obtain the file File["ExampleData/StocksTemplate.nb"] referred to in session 14 Automated Report generation under the heading Automated report generation? I'd like to see it to help my understanding of the driver linkages to the template. Thank-you, John Burgers

Hi, John, try to run this command: FindFile["ExampleData/StocksTemplate.nb"]

Exercise 4.3.3

After a number of trials: I think the sonnet CVIII is not in the correct cluster as demonstrated in the expected output. Please check.

Unfortunately, it seems like the cluster membership can change when FindClusters is used with default options, between different systems and different versions of the Wolfram Language. On my installation of Mathematica 12.3 I am getting the following clustering:

{{"XXI", "CLIII", "V"}, {"LXXIV", 
  "XXXVII"}, {"XXVIII"}, {"XLIII"}, {"CVIII", "CXVIII", "CXV"}}

which is different from the expected output I had originally provided:

{{"XXI", "XXVIII", "CVIII"}, {"LXXIV", 
  "XXXVII"}, {"XLIII"}, {"CXVIII", "CXV"}, {"CLIII", "V"}}

I will update the exercise. Meanwhile feel free to email your Exercise notebook for 3.3.

Posted 3 months ago

Vincent Feng, your brilliant. I never knew these were included with the distribution of Mathematica ! NotebookOpen[ FileFind[ "ExampleData/StocksTemplate.nb" ] ] worked !! Have a great Day! Thank-you, John

Posted 3 months ago

The built-in classifier "ProgrammingLanguage" of ex 4.1.2

runs on the cloud but not in my version 12.2 .0 desktop in Windows 10. It is not in the Wolfram Documentation for my desktop version.

I am assuming its experimental, if it is , can you just check that if it is used in a question that it is in the latest distributions of Mathematica ...... I spent an age trying to get this to run on my desktop, before in desperation running it in the cloud .

Posted 3 months ago

That's weird.

The reference says that "ProgrammingLanguage" was introduced in 2019 with version 12.0.

Maybe this helps to narrow down the problem: On my machine (Linux), Mathematica performs the task quite fine - I get exactly the expected result.

enter image description here

Hi @doug Beveridge, The "Programminglanguage" classifier is definitely available in the latest version of the Wolfram Language. It has been available since its introduction in 2018 with version 11.3. If you are unable to access it or use it in your version of the Wolfram Language, could you please contact the technical support team at https://www.wolfram.com/support/contact/email/?topic=technical. I am worried if it might be indicative of some other issue with your installation.

Thanks

Posted 3 months ago

Hi Abrita

I think it has something do with the way the string "/^.?$|^(..+?)\1+$/" is being parsed.

enter image description here

I could not get my code to work in the desktop and I cut and pasted it straight into the cloud and it worked. After my post on here I cut and pasted the same code from the cloud into my desktop version and it first contacted the Wolfram server and did a download and worked. All rather strange.

(it did not help when you do a search for "FacialAge" it comes up as a (Built-in Classifier) and if you do a search on ProgrammingLanguage it comes up as an Entity )

Which documentation page are you taken to when you paste the following in the search box at the top of the documentation window? (or do you find the page does not exist on your system?)

ref/classifier/ProgrammingLanguage

enter image description here

Also are you able to evaluate and see the putput of the following?

Information[Classify["ProgrammingLanguage"], "Classes"]
Posted 3 months ago

If you do a search on the keyword "ProgrammingLanguage" it takes you straight to the Entity . The keyword is overloaded but you will not know it from that search

enter image description here

Posted 3 months ago

If you do a search on the "search for all pages containing "ProgrammingLanguage" then you come to see its overloaded .

enter image description here

I have submitted my exercises solution and send to the course team my submission email just minutes ago. my intention is level I certificate, thank you very much.

Posted 2 months ago

Hello group,

Could someone please clarify the instructions to exercise 4.3.2. The instructions seem straightforward and I interpret them to mean that you would like all words within the given 100 word list that have equal length to be clustered or grouped into a separate sub-collection for each word length. In other words, all strings containing 13 characters are collected into one sublist, all strings containing 12 characters are collected into a different sublist, and so on. The expected output is not represented this way. Perhaps I am not understanding the instructions correctly. Please advise.

Thanks,

Roger

Hi Roger, If you use FindClusters to cluster the group of 100 words given in the exercise, it will create clusters based on the default distance metric for strings - to show the similarity/dissimilarity between the strings themselves. Instead this exercise wants you to use a numeric feature for each word (StringLength) to group them into clusters.

FindClusters will create the clusters automatically by grouping the numbers (representing the length of the words) into appropriate clusters. We need not have just one cluster for each number. We are trusting FindClusters to come up with a reasonable number of clusters for this data. Four, five or six lettered words can end up in the same cluster.

Hope this helps.

Posted 2 months ago

Thanks Abrita,

That clarified the intent. Autograder confirms.

Roger

Posted 2 months ago

I apologize if someone has already discussed this, but I suspect that the option ColorFunctionBinning for GeoRegionValuePlot has changed its default behavior (or else my installation is screwy). Almost all the examples in the documentation show discrete color bins in the legend (as does the Expected Output in the exercises), but the documentation for my installation says the default is None. When I rerun the examples in the documentation with no explicit settings for ColorFunctionBinning or ColorFunction, I always get a continuous gradient of colors in the legend, not the output shown originally with discrete bins. In other words, it looks like the examples were not rerun when the function was updated in 2020 (or, again, my installation is screwy).

As for the corresponding exercises, I can reproduce the graphics only by adding explicit settings for ColorFunctionBinning, which the autograder seems to deprecate (of course it does).

I'm running version "12.2.0 for Microsoft Windows (64-bit) (December 12, 2020)" on Windows 10.

Thanks, Ron Goetz

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract