Message Boards Message Boards

8 Replies
9 Total Likes
View groups...
Share this post:

Strange Mathematica 9 problem

Posted 11 years ago
I've been having a strange problem with Mathematica 9.  I'll be working on a document, and Mathematica will beep and a dialog box will appear saying:

"The notebook's file /Users/.../.../.../notebook.nb has changed outside of Mathematica.  The notebook has been renamed to Untitled-2.  Mathematica has a complete record of changes made to the notebook, but might not be able to recover some of the unchanged cells.  You can open the exsting file again to reconcile any unsaved changes."

Everything hidden by closed tabs will be deleted.  I have very long and intricate notebooks and it is often very difficult to resolve the "changes".  This happens to any open notebook, regardless of whether it has been or is currently being edited.  It also happens to minimized windows.

For reference, I have a MacBook Pro (~1.5 years old) running Maverick.  I upgraded to both Mathematica 9 prior to Maverick, but do not remember if the problem existed with Mounton Lion as well.  I tried reinstalling Mathematica, including removing all of the files in /Users/../Library/ and all preference files.  The problem persists.  I am not running any antivirus software.  It also seems to be independent of other applications that I am running -- it even occurs when Mathematica is the only application I am running (not including OSX background processes).

Has anyone else experienced this problem?  Does anyone have a solution?
8 Replies
Posted 8 months ago

I can verify that this error is still an issue in Nov. 2023. It's a google drive issue, for sure.

POSTED BY: David Talaga
Posted 3 years ago

This is probably because of a Google Drive bug. It changes modified timestamps. It should never do that.

POSTED BY: Rohit Namjoshi
Posted 3 years ago

I am having a similar problem for the last few weeks, since changing from Google Backup & Sync, to Google Drive for Desktop. I keep my notebooks on Google Drive.

If I open a notebook (for example Calcs.nb), and save it (for example with Command-s), the notebook is saved under the correct name and time stamp. However, if I make any additional changes to the still-open notebook, Mathematica informs me that the file containing the notebook has been changed by another process, and renames the open notebook to Untitled.nb (or Untitled-N.nb, where N is a natural number). I can then save under another name, or overwrite the earlier save; but as soon as I make an additional change the problem recurs.

Changing FileChangeProtection to "None" in Mathematica Preferences, as suggested above, seems to have solved the issue.

POSTED BY: Carl Gwinn

I am having a similar issue with Mathematica 12 but it is triggered due to interactions with Google drive. I back up the directory where my .nb file resides using google drive backup and synch. If I disable Google driving backups, everything works. If I enable it, as soon as I save a file, Google drive backs it up, and immediately, I see this error. What is interesting is that when I enable Google drive backups, I am able to monitor the "last date change" of the file and I can see that its last date changed is not changing as a result of Google drive backups. So I am a bit confused why Mathematica is bothered by it. But I am guessing somehow Google drive "touches" the file, and that is enough to create a problem.

In my case, changing FileChangeProtection to "Locking" (see Bruce and Sean's responses) also seems to have solved the issue.

SystemInformationData[{"Kernel" -> {"Version" -> 
     "12.1.0 for Mac OS X x86 (64-bit) (March 18, 2020)", 
    "ReleaseID" -> " (6771490, 2020031802)", ...
POSTED BY: Siavash Mirarab
Posted 3 years ago
POSTED BY: Stephen Judd
A few others (including me) have seen this.  It has been around a few years. 
There hasn't been enough consistency (local drive vs. network drive,
size of file, MacOS level, etc) for developers to figure out the cause.

For now, the workaround is to turn off checking for notebook changes
outside of Mathematica. The steps are
  - open the Option Inspector (under the Format menu),
  - Set scope to Global preferences
  - in the lower part of the window,
      * click Notebook Options
      * click File Options
      * click FileChangeProtection
      * click the box-with-triangle to the right of the option name
      * in the menu that opens, select None.
See the attached screen shot.

POSTED BY: Bruce Miller
Posted 11 years ago
I noticed that several people have encountered the same error, but I haven't seen anyone complain that massive portions of their notebooks are deleted.  In my particular case, I'm glad that it alerts me to changes so that I don't overwrite a semi-complete notebook with a mostly empty one.
There's  a number of reports about this online, but it isn't clear what is changing the files outside of Mathematica to trigger this.

You may want to report this issue to wolfram technical support ( along with your Mathematica activation key or license number.

I would include a Mathematica notebook where you have evaluated SystemInformation[]. This will provide them with more information about the issue.

One way to get rid of this issue is to disable Mathematica's file change protection. You can do this in the option inspector  (Format > Option Inspector):

1. Click "Selection" in the first drop down menu and change to "Global Preferences".

2. Navigate to Notebook Options -> File Options -> FileChangeProtection.

3. Set this field to None.
POSTED BY: Sean Clarke
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract