Message Boards Message Boards

0
|
6395 Views
|
2 Replies
|
3 Total Likes
View groups...
Share
Share this post:

Plot3D does not show result on Linux Mint 17

Posted 10 years ago

I just installed Mathematica on my laptop. I use Linux Mint 17. My problem is that I cannot see any 3D graphics. Or more precisely, when I open the Plot3D reference page, I can see the 3D graphs, but when I run the codes myself, the graphs disappear. On the other hand, in the advanced Manipulate functionality tutorial I don't even see the original 3D graphs, just a blank screen of the correct size. 2D graphics work fine. As I understand, I probably have to do something with the video drivers, but if you could direct me to some detailed directions, it would be helpful. Thanks, Ferenc

some details:
operating system: Linux Mint 17
graphics card: AMD/ATI RV320/M22 Mobility Radeon x300
drivers: X.Org 1.15.1 ati,radeon
GLX renderer: Gallium 0.4 on ATI RV370, GLX version 2.1 Mesa 10.1.0

POSTED BY: Ferenc Beleznay
2 Replies

Some boilerplate I have for similar issues:

****
Running Mathematica with the following options will work around the problem in many instances:

mathematica -mesa -defaultvisual

If this works, then the problem is with 3D hardware acceleration.
If your computer uses a NVIDIA graphics card, try running Mathematica with the following command:

$ env MATHEMATICA_GL_FBO=1 mathematica

Or similar for your shell.

If this works, you can try adding this environment variable to the bashrc/cshrc/whatever. You may also wish to try upgrading the video driver(s) or changing video driver from a closed-source version to the open-source version, or vice versa.

If you are running multiple monitors, check /etc/X11/xorg.conf. There is a known driver issue when "xinerama" is enabled. If you are using an NVIDIA graphic card, press Ctrl+Alt+F1 (which switches to the terminal), kill X (usually by running /etc/init.d/gdm stop, where "gdm" could be "xdm", "slim", or "xdm", depending on the distribution), then run the following:

# mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup 
# nvidia-xconfig 
  • restart the display manager (something like /etc/init.d/gdm start). This will have only one screen configured.
  • run the nvidia-settings command as root and
  • set up the second screen using "TwinView",
  • then save the changes to the Xorg configuration file.

Note:
The -mesa option causes the Mathematica graphics system to use a software version of OpenGL, instead of a hardware-accelerated version of OpenGL. This will significantly slow down both complex 2D graphics and most 3D graphics. ****

POSTED BY: Bruce Miller
Posted 10 years ago

Thank you for the detailed response. Running Mathematica with the mesa option worked. Th card is not NVIDIA, so I did not try the other solution.

POSTED BY: Ferenc Beleznay
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract