Message Boards Message Boards

4 Replies
8 Total Likes
View groups...
Share this post:

auto numbering style question

Posted 12 years ago
I would like some cells (ItemNumbered, SubItemNumbered, SubSubItemNumbered) to appear like this:

 1 my first itemNumbered
     a first subitemnumbered
     b second
         i  first subsubitemnumbered
         ii second
     c ...

So far by using my own stylesheet and the formating options I have not been able to remove the "." after the number, and I can only get things like a.b.c or i.ii.iv

Any suggestion?

Thank you,
POSTED BY: Luc Barthelet
4 Replies
Posted 12 years ago
Luc approved Barthelet:
I am still looking for help on this subject...
I'm not sure why you're still looking.  Mings answer, if not the most concise, is correct.  This is controlled by the CellDingbat, which you can set to whatever you like.  So, for example, this will give you an ItemNumered with just the number:
Cell[StyleData["ItemNumbered"], CellDingbat->Cell[TextData[{CounterBox["ItemNumbered"]}], FontWeight -> "Bold"]]
And this will give you just a roman numerical for SubitemNumbered
CellDingbat->Cell[TextData[{CounterBox["SubitemNumbered", CounterFunction->RomanNumeral]}], FontWeight -> "Bold"]]
Rinse, lather, repeat, for all relevant styles.
POSTED BY: Itai Seggev
I am no expert here but I tried the following.

(I am using Mac.)

1. Open Format -> EditStyleSheet
2. In the opened "Private Stylesheet Definitions for (Untitled - 3)", type ItemNumbered in the input field of "Enter a style name: " and hit enter.
3. Click on Default.nb stylesheet.
4. In the Default.nb stylesheet, open Style For Body Text -> Display -> List -> Numbered and the first cell is the local definition for style ItemNumbered. Unformat it (Command+Shift+E). Copy everything in that cell.
5. Go back to "Private Stylesheet Definitions for (Untitled - 3)" and unformat the "Local definition for style ItemNumbered:" cell, delete everything and paste the copy from step 4. Then modify CellDingbat option to 
CellDingbat->Cell[TextData[{CounterBox["ItemNumbered"]}], FontWeight -> "Bold"]
6. Finally, format the cell (Command + Shift + E)

then the "." should go away.
POSTED BY: MinHsuan Peng
I am still looking for help on this subject...
POSTED BY: Luc Barthelet
You are all correct, this totally does it! THANK YOU
POSTED BY: Luc Barthelet
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract