Message Boards Message Boards

16 Replies
2 Total Likes
View groups...
Share this post:

Can't open a notebook in Mathematica 10

Posted 10 years ago

Hi, recently I bought Mathematica 10 for school however the first nb that I created is impossible to open, when I try to open it warns me about the dangerous dynamics, but when I press enable dynamics nothing happens. This also happened with the other 2 files I have created.

POSTED BY: Hansel Montuffar
16 Replies
Posted 8 years ago

I think I may know what is happening in this case. If you open the problem notebook in a text editor, it doesn't contain any of the information in the original file. Instead, it seems to contain the instructions to display the welcome/exit page. I think that somehow, the contents of the welcome/exit page are being saved over the notebook contents. That is why when you open the notebook it appears that the welcome/exit page just stays put. Its actually opening the notebook correctly, but the notebook has been replaced with the welcome/exit page. Tough luck.

I would recommend saving through the file menu in the future, and never just clicking the close button (X) to save.

POSTED BY: Erich Gust
Posted 10 years ago

I am getting this same issue. I had a notebook that I saved by closing it with the X button and it saved a file, but was corrupted in the same way as described as above. I made test notebooks and saved them with the same method and no files ever appeared.

I sent a report to Wolfram Support.

POSTED BY: Warren Casey
Posted 10 years ago

It doesn't seem to work, for me at least. In the beginning I also had this problem. And it was very frustrating to see that happening. I have disabled the closing window... and the problem persisted, but in another form:

Let's say you have a new notebook containing some code. Without saving the work, close the notebook by pressing "X"; it asks if you want to save your work; indicate the location and save. Now, if you want to open this recent notebook, first try and find it!

POSTED BY: Sandu Ursu

b) A cheap-looking thing to try, if the notebook opens far enough to select cells, is to select all the cells (or all the Input cells), copy them, and paste them into a new notebook.

If the problem is invisible characters, that might help.

Using Edit menu - Copy As - Plain Text would be better, in terms of leaving accidental junk behind. Outputs, especially graphics, might need to be rebuilt.

c) The attached notebook has a notebook de-corrupter that might be helpful.

The symptoms are unfamiliar to me, so I am offering multiple suggestions.

POSTED BY: Bruce Miller
Posted 10 years ago

No, it doesn't work for me either. But in your notebook uncorrupter, I saw a link and followed it to this page:

I also tried what is suggested there. From what I understand, if I follow the instructions there, mathematica should open a new notebook which contains everything that could be "saved" from the specified notebook. What seems odd to me is that, at least in my case, the new notebook is completely empty. Its almost as if the procedure regards every single line in my old notebook as corrupted. I dont know much about mathematica and what one can do wrong, but as I said, I just did some numerical calculations in this notebook. I can't imagine what has happened here.

Anyway, I'm just trying to give as much information as possible, so that maybe somebody can come up with a solution. (Thanks for answering in the first place.)

POSTED BY: Johannes Wirtz

The next step would be sending the notebook, an explanation of the behavior, and what you tried to

POSTED BY: Bruce Miller

Try this to open the problem notebook:

File menu - Open
Locate the file and click ONCE to select it
Click the Options button low in the file navigator window
In the window that opens, check "Parse and Load Entire Notebook .."
Close the second window
Click OPEN in the file locator window.

See the screen shot.

This will rebuild some internal information that might be keeping the notebook inert.

enter image description here

POSTED BY: Bruce Miller

Checking the "Parse and load entire notebook into memory upon reopening" box worked for me. Thanks!

POSTED BY: Rauan Kaldybaev
Posted 10 years ago

I've got the same problem. I got mathematica 10 for work, and I have two files. One opens without any trouble, with the other one it is the same issue as described above. (The file contains possibly unsafe dynamic content) Clicking on x or on "enable dynamics" does not seem to do a thing. Both files just contain some simple calculations and no actual programming (but rather a lot of those, so recreating them would waste several hours...), therefore I can't imagine why the problem occurs. But maybe this is just because I'm new to mathematica. Anyway, help is much appreciated because I can't do a thing right now :(

POSTED BY: Johannes Wirtz
Posted 10 years ago

Another thing: We tried to open that file on a different machine and it didn't work either, just as described before. (Windows 7 and Ubuntu in this case) So it should be an issue with the files?

POSTED BY: Johannes Wirtz

A little update I don´t know why but after i created around 10 corrupted notebooks the eleventh and beyond work perfectly. maybe it´s a corrupted file or something

POSTED BY: Hansel Montuffar
Posted 10 years ago

I have the exact same problem. Did you found an answer? :(

POSTED BY: Alfredo Koc

Didnt work

POSTED BY: Hansel Montuffar

The window in your screen-shot is the exit screen. I'm not sure why that is appearing. Do the three buttons below it ("New Notebook", "Open...", "Quit") work?

If you haven't tried this yet, please follow the instructions in this article:

POSTED BY: Sean Clarke

Thank you for answering; I can open Mathematica create a new notebook and be able to work in it, i have created 3 nb so far the first one was the first one that I couldn't open then I created a new one where I only input one command i can open that however the third one that I created has the same issues as the first one.

Im using Windows 8.1, however I tried to open the file in a friend's computer who has Windows 7 and the same problem occurred.

When I try to open the file directly from my documents carpet or from Mathematica this screen appearswolfram problem

When I press enable dynamics only the warning disappears and the nothing happens no matter how much time I left the computer without working, when I close the window it reopens whitout the bar.

POSTED BY: Hansel Montuffar

Is Mathematica opening normally otherwise? Are you able to run it, create a new notebook, type in it, save it, restart Mathematica, and then reopen the file?

What operating system are you using? When say that nothing happens after you click "Enable Dynamics", do you mean that the notebook doesn't appear on the screen anymore?

POSTED BY: Sean Clarke
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract