Message Boards Message Boards

1
|
5199 Views
|
4 Replies
|
4 Total Likes
View groups...
Share
Share this post:

Mathematic 9 and 10 Both Installed and Financial Data Doesn't Work In 9

So, I installed Mathematica 10 the other day alongside 9 and let it remove Mathematica 8. While it was installing, I briefly saw a message about Mathematica 9 Extras being removed. At the time, I didn't think much about it as I assumed that 9 would still continue to be able to use the Extras from 10.

I'm not sure if FinancialData is one of the Extras, or not, but it is no longer working in 9. If I try something simple like:

FinancialData["GE"]

I just get $Failed. Of course, that works just fine in 10. Is there any way to recover this functionality in 9 while still keeping 10 installed?

POSTED BY: Tim Mayes
4 Replies

Arnoud,

Removing the backslashes did the job. Thank you very much!

Tim

POSTED BY: Tim Mayes

Arnoud,

Thank you for replying, but that didn't work. Here is what I get:

In[1]:= PacletUninstall /@ PacletFind["\*FinancialData\*"]

Out[1]= {}

In[2]:= Quit

In[1]:= FinancialData["GE"]

Out[1]= $Failed

What if I reinstall Mathematica 9? Or, would that possibly cause problems with 10?

POSTED BY: Tim Mayes

Can you try it without the backslashes () before the asterixes (*)? This was an issue with my post editing. (It may still not work, but I want to make sure this has been tried).

POSTED BY: Arnoud Buzing

Timothy,

The Extras have nothing to do with FinancialData. (The Extras installs the CDF browser plugin)

It is more likely that your FinancialData paclet somehow became incorrect.

Try the following:

  • Quit Mathematica 9 & 10
  • Launch Mathematica 9
  • Evaluate: PacletUninstall /@ PacletFind["*FinancialData*"]
  • Evaluate: Quit
  • Evaluate: FinancialData["GE"]

Let me know if that does not solve your problem.

POSTED BY: Arnoud Buzing
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract