Message Boards Message Boards

3 Replies
3 Total Likes
View groups...
Share this post:

Understanding Mathematica's seeming inability to solve a simple DiffyQ

Posted 10 years ago

I'm doing a work-through of Boyce/DiPrima's EDE (10th Ed), and one of the problems is to solve explicitly the following equation:

y^2*(1-x^2)^(1/2) dy = arcsin[x] dx

Now I was ultimately able to solve it manually. But for grins (or laziness) I initially tried my newly-purchased Mathematica v.10 on it, and couldn't convince "DSolve" to solve it. Clearly I must be doing something wrong, because I've only been playing with my new best friend for a few days, and I'm already convinced he/she is WAY smarter than I am (not that this is any great feat).

Anyway, when couching the 'DSolve' command as follows:

DSolve[y'[x] == (ArcSin[x]/(1 - x^2)^(1/2))/y[x]^2), y[x], x]...

...I get the empty set symbol (ie: {{ }} ...)

If I try to do it implicitly (which I'm not sure DSolve understands):

DSolve[(y[x]^2)*y'[x] == ArcSin[x]/(1 - x^2)^(1/2), y[x], x]...

...I get an error message stating that the given equation is not a differential equation (I'm thus assuming here that DSolve cannot accept input implicitly).

So I'm stumped: the (seeming) 'right' way gets me the wrong answer (ie: I know there is an explicit solution), and I don't seem to be able to input the equation implicitly. Anyone see what I'm doing wrong?

Thanks in advance!

POSTED BY: Lawrence Cosner
3 Replies

Anyway, when couching the 'DSolve' command as follows: DSolve[y'[x] == (ArcSin[x]/(1 - x^2)^(1/2))/y[x]^2), y[x], x]... ...I get the empty set symbol (ie: {{ }} ...)

It works for me. You have an extra ) in there after y[x]^2. So I do not know how you got an answer instead of a syntax error. May be some copy/paste error. Any way, here is on version 10.02

Clear[y, x];
DSolve[y'[x] == (ArcSin[x]/(1 - x^2)^(1/2))/y[x]^2, y[x], x]


{{y[x] -> -(-(3/2))^(1/3) (ArcSin[x]^2 + 2 C[1])^(1/3)}, {y[x] -> (3/2)^(1/3) (ArcSin[x]^2 + 2 C[1])^(1/3)}, 
  {y[x] -> (-1)^(  2/3) (3/2)^(1/3) (ArcSin[x]^2 + 2 C[1])^(1/3)}}
POSTED BY: Nasser M. Abbasi
Posted 10 years ago

Thank you VERY much. I'll try your (corrected) version as soon as I can. (Currently my nurse is glaring at me, as I'm playing with my new best friend, instead of doing what I'm supposed to be, which is seeing patients...)

POSTED BY: Lawrence Cosner
Posted 10 years ago

Not sure if this is helpful, but I thought I'd post it JIC. I was working on my laptop today (I have one of your 'prime' or 'premium' accounts, so I can run your product on my main work-oriented computer, and also on my laptop). The problem I'd encountered was on my desktop, but since I was there at the laptopI tried your input. Worked perfectly. Tonight, just out of compulsion, when I got back to my desktop I tried it on the same (still open) notebook that I've been playing with for the last 36 hours. Interestingly, I got the 'null set' result? So, being the suspicious geek that I am, I closed that notebook, shut Mathematica down, restarted and tried again. Works normally, gives right answer. So there was something broken in the notebook or the kernel.

I'm telling you this only in case this little vignette helps w/ some sort of potential instability in long-open windows that you guys may be working on. Thanks again for helping me!

POSTED BY: Lawrence Cosner
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
or Discard

Group Abstract Group Abstract