Message Boards Message Boards

GROUPS:

Mathematica and Raspberry Pi 2

Posted 4 years ago
24939 Views
|
9 Replies
|
7 Total Likes
|

Will the free version of Mathematica work on the newly announced Raspberry Pi 2?

9 Replies

The Wolfram Language (and Mathematica) are available on the Raspberry Pi 2 (and it runs great!).

Just run these two commands in a terminal:

sudo apt-get update
sudo apt-get install wolfram-engine
Posted 4 years ago

Hello Arnoud, will the problems with connecting with the Remote Development Kit from the Laptop to the Pi be solved with Mathematica 10.0.2 and/or the new Wolfram version for the Pi? Will there be an updated/bugfixed version of the Remote Development Kit?

Arnoud this might be of interest not only me but also a few other people out there who are interested in using the wolfram language controlling processes or robots: Could you please provide a control systems tutorial (or a demonstration, as it is called here) for the Raspberry Pi + wolfram language? Could you please show how to access in wolfram the sensors and actors of the Navio+ HAT for the Raspberry Pi (the one from EMLID) and process the signals with the wolfram language's control systems capabilities? (Maybe one classic and one state space controller example would be great!) Can you please show also what has to be done so that the wolfram language will spread the calculations of the implemented controller over all 4 kernels of the raspberry pi whenever possible?

Thank you and kind Regards! Björn

Hi.I have some troubles Pi2 with Mathematica. Mathematica can not launch sub kernels.

please tell me the solution of this trouble. thank you.enter image description here

Attachment

Attachments:

We are working on a fix which addresses this (it's a licensing issue: you should be able to use a total of 4 kernels and 4 frontends on a Raspberry Pi (so 8 total processes), but currently the maximum you can get is 3 total (kernel+frontend).

Thank Arnoud, please let me know after the problem has been fixed . I am looking forward to it. In additon,licesedCores are 16,,,,.enter image description here

You should be able to update now to a version which has this issue fixed:

sudo apt-get update
sudo apt-get install wolfram-engine


enter image description here

When it will be avaiable fully functional Mathematica on Raspberry Pi ? You have written Arnoud that it will be ready up to one week ago. I'm concerning to buy Raspberry Pi 2 and one of benefits to buy additional RPI (I am using RPi B+ now) is that Mathematica will be avaiable fully funcional. I will plan to use Mathematica and Wolfram Language as primary tool for my educational project http://www.kokos.hol.es/project.html unfortunatelly avaiable now only in polish language because I address the project to young people from secondary schools in Poland. I will be gratefull for answer.

regards

Łukasz

Łukasz,

You should be able to update now:

sudo apt-get update
sudo apt-get install wolfram-engine


After updating the Wolfram Language $Version variable should be this:

pi@test-pi ~ $ wolfram
Wolfram Language (Raspberry Pi Pilot Release)
Copyright 1988-2015 Wolfram Research
Information & help: wolfram.com/raspi

In[1]:= $Version                                                                                                                                                                                               

Out[1]= 10.0 for Linux ARM (32-bit) (February 3, 2015)

Ok thank You I will try do update.

regards

Łukasz

Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract