Message Boards Message Boards

0
|
3959 Views
|
1 Reply
|
0 Total Likes
View groups...
Share
Share this post:

GeoPath[] confused by certain coordinates?

Posted 9 years ago

Hello Group:

I ran a GeoGraphics[] sample using GeoPath[] like this and it runs as expected:

With[{locations = {GeoPosition[{-35, -55}], GeoPosition[{70, 100}]}}, 
 GeoGraphics[{{Blue, GeoPath[locations, "Geodesic"]}}, 
  GeoRange -> "World", GeoProjection -> "Robinson"]]

I tried to change the endpoints of the path to Hong Kong and Mexico City. First I tried this using an entities, like what is shown (attached).

It produces a line that goes into space. The following tests all produce the same result:

reversing the endpoints

substituting the GeoPosition[] explicitly (i.e. {22.284, 114.15}, {19.43, -99.14} )

changing the GeoProjection -> "Albers"

So I cannot get this to work.

Any help with this issue is appreciated.

Environment is Win8.1, Mathematica 10.1

Attachments:
POSTED BY: Aeyoss Antelope

We are aware of this and our teams are looking into it. In a meantime a workaround is manually selecting a GeoRange in which the path does not need to be broken in two pieces.

POSTED BY: Vitaliy Kaurov
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract