Message Boards Message Boards

GROUPS:

Plot is not showing: Out[] = -Graphics-

Posted 6 years ago
16243 Views
|
3 Replies
|
0 Total Likes
|

Newbie has a plot question. The graph is not showing! Not even an empty graph. What happened? Help, please!

In[4]:= Plot[Sin[x],{x,0,2}]    
Out[4]= -Graphics-
3 Replies

Hi,

one would need more information. Are you running Mathematica from the command line? Then it would be quite normal that you don't get the graphical output.

enter image description here

If you are running Mathematica in the standard graphical user/notebook interface you should see the plot as expected.

enter image description here

Also it might be useful if you could post the output of this command:

$Version

Cheers,

Marco

PS: You might also want to see this and this.

Hi. Please see this article which shows you how to fix this configuration issue with your copy of Mathematica:

http://support.wolfram.com/kb/12490

Please let me know if you have any questions about it.

Posted 25 days ago

If you are running it from command line then you can export the graph to see it.

  • It usually exports to the installation location.
  • May need to run it as admin as installation location file changes request admin rights.
  • Example export:

In[4]:= p2 = Plot[Sin[x],{x,0,2}];                                                                                      
In[5]:= Export["p2.jpg",p2];
Reply to this discussion
Community posts can be styled and formatted using the Markdown syntax.
Reply Preview
Attachments
Remove
or Discard

Group Abstract Group Abstract